Fuse panel on right side footwell?? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-14-2005, 01:58 AM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default Fuse panel on right side footwell??

Hey everyone,
Anyone have a picture and a diagram of which fuse is for what? My chiltons book and Alldata dont mention it. I only ask this because now i have electrical issues, No cruise, no ac, no courtesy lamp.. I had a pivot switch replaced in the column and this happens along with a code 26 " Quad driver module " Not sure but i think they must have grounded something in the coulmn and blew a quad driver in the pcm. Does this sound right to you guys?

Thanks,
Sellncars
sellncars is offline   Reply With Quote
Old 04-14-2005, 02:47 AM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

Do you have a PCM that you could swap in?
LakevilleSSEi is offline   Reply With Quote
Old 04-14-2005, 11:06 AM   #3
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

sellncars, I had all the fuses in the relay center (that'* what it'* called) all detailed in a reply last night, and my cable took a crap. Nevertheless, none of those fuses is your problem.
willwren is offline   Reply With Quote
Old 04-16-2005, 02:04 AM   #4
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default

I'm going to the salvage yard in the am to grab a computer. I took the car back to the shop on Wednesday night and they worked on it all day long yesterday, i got it back today and the code was still there, until i cleared them, they forgot to unhook the battery, now it is gone, but the a/c doesnt work, the cruise doesnt work, the courtesy lights in the doors and interior dont work anymore like they did. I'm tired of taking it to a shop with a half assed mechanic that forgets to clear the codes and breaks wires in the steering column. Thats what they did to mess it up the first time, the kid told me that he broke a few wires while fishing the new wires down through. I think they grounded the wire and it fried part of the computer. I will post when i get it back together on saturday night.

Thanks guys,
Sellncars
Quote:
Originally Posted by LakevilleSSEi
Do you have a PCM that you could swap in?
sellncars is offline   Reply With Quote
Old 04-16-2005, 02:05 AM   #5
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default

Thanks for trying. I'm going to try a used computer with my prom installed.

Thanks,
Sellncars
Quote:
Originally Posted by willwren
sellncars, I had all the fuses in the relay center (that'* what it'* called) all detailed in a reply last night, and my cable took a crap. Nevertheless, none of those fuses is your problem.
sellncars is offline   Reply With Quote
Old 04-18-2005, 07:16 PM   #6
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default

Hi guys,
Problem repaired. I took the car back to the garage, they had it all day long. I picked it up on friday, they said they broke 2 wires in the column, they repaired the wires. I drove the car approximately 600 feet and the cel came on. I didnt have time to take it back that day. I came home from the auction and noticed that the radio stations were still set, they never disconnected the battery. I cleared the codes, and poof no more codes, but the cruise and A/C still didnt work.

So on Saturday i went to the junk yard grabbed a different PCM, same service code # took my prom out of my cars pcm and replaced it in the other pcm. No difference. I messed around for a while and found a blown 15 amp fuse on the pass side footwell, My A/C blows ice cold again and i have cruise. I also have a spare PCM. I called the garage and mentioned about the air bag coming off the car without disconnecting the battery and pulling the fuse. Thats a dumb move on the mechanics part.

Thanks guys,
Sellncars
sellncars is offline   Reply With Quote
Old 04-18-2005, 09:28 PM   #7
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

That'* interesting.....I didn't see a fuse in my FSM'* listed on that panel that would affect the AC. I gotta look at that again, but I'm glad you got it working.
willwren is offline   Reply With Quote
Old 04-19-2005, 12:15 AM   #8
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Apr 2004
Location: Endwell, NY
Posts: 190
Thanks: 0
Thanked 0 Times in 0 Posts
sellncars is on a distinguished road
Default

Well, i think it had to do with that fuse. My A/C works great again. Maybe a fluke? Thanks for all of your help though, it'* nice to have another avenue to go to.

Thanks,
Sellncars
Quote:
Originally Posted by willwren
That'* interesting.....I didn't see a fuse in my FSM'* listed on that panel that would affect the AC. I gotta look at that again, but I'm glad you got it working.
sellncars is offline   Reply With Quote
Old 04-19-2005, 11:29 AM   #9
Member
Posts like a V-Tak
 
Join Date: Jan 2005
Location: Cincinnati, OH (westside!)
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
IamMrHart2u is on a distinguished road
Default

hey you know what? I just went through the same thing with the A/C and the 15 amp fuse blowing, but I had QDM 4 fault codes, I swaped computers from the bone yard and problem solved, the fuse that blew on mine was the cruise/misc engine, though I have not swapped the eprom chips as of yet, there is nomore fuse blowing going on and my a/c works again
IamMrHart2u is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What is the MALL fuse in my fuse panel? joes04bonneville 2000-2005 1 12-03-2010 01:38 AM
Water found in Right rear footwell.... roadhound General GM Chat 3 10-21-2008 10:37 AM
Right side fuse panel emeraldrose 1992-1999 4 05-01-2008 01:49 PM
Passenger side fuse panel egladman Pontiac 1 09-05-2007 08:21 AM
passenger side fuse panel nagel79 Everything Electrical & Electronic 2 02-13-2007 09:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.