Front Trans mount broken, clean in half..Fixed - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-23-2007, 12:22 AM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Feb 2005
Location: Toronto, Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Dutch2005 is on a distinguished road
Default Front Trans mount broken, clean in half..Fixed

So today I'm on my way home from work (2 miniute drive) and I stop at a light.
Light turns, I give her light throttle and I see a small puff of white smoke from under the hood ?

When I got home I open the hood with the engine still running, to see if anything is leaking (thinking maybe tranny line) and what do I see, front mount (tranny mount) is busted clean in half.

It looks like the engine is sitting kinda low like its on the cross member, but I'm not really sure.
I couldn't jack her up to take a look cause, the good jack is holding the engine in the wifes car (doing water pump, etc.).

I tried searching but I only found a bunch of posts with the newer Bonne'* having this problem.

How common is it for these mounts to brake in the 92/93 '* ?

Is there a better replacement than factory or just go with OEM ?

Thanks in advance,
Dutch
Dutch2005 is offline   Reply With Quote
Old 08-23-2007, 08:36 AM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Mounts break..it'* common enough although yours sounds to have broken very well.

Replace with the stock mount. There'* really nothing "better" or available, unless you want to try upgrading to the 94+ mount that has a shock absorbing strut built into it.
BillBoost37 is offline   Reply With Quote
Old 08-23-2007, 09:04 AM   #3
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

The stock $30 replacement mount will outlast your ownership of the car. For the record, this isn't an engine mount. It'* the front trans mount. The are aging. I can name you a few that have broken in the last year or two.
willwren is offline   Reply With Quote
Old 08-23-2007, 09:34 AM   #4
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Feb 2005
Location: Toronto, Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Dutch2005 is on a distinguished road
Default

Thanks for the quick reply and the info. Going to go grab one now.

Dutch
Dutch2005 is offline   Reply With Quote
Old 08-23-2007, 09:42 AM   #5
Senior Member
True Car Nut
 
Join Date: Jan 2006
Location: NEBF:06,07 | NYBF:06,07 | ONBF:06,07 | CNBF:06 & more............
Posts: 8,029
Thanks: 0
Thanked 0 Times in 0 Posts
bandit is on a distinguished road
Default

Just wondering.. Is the 92/93 mount diffrent then the 94/95'*?

Seems so... because its like 80$ less then mine


*edit*

yup just found out my answer
bandit is offline   Reply With Quote
Old 08-23-2007, 09:53 AM   #6
Senior Member
True Car Nut
 
Join Date: Feb 2002
Posts: 3,993
Thanks: 0
Thanked 0 Times in 0 Posts
JimmyFloyd is on a distinguished road
Default

yeah, I managed to break two in my first bonneville and just recently replaced the one in my 93 SSEi.
JimmyFloyd is offline   Reply With Quote
Old 08-23-2007, 11:10 AM   #7
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

The 94/95 mount has a shock absorber on it. 91-93 doesn't. I don't see any particular advantage to either design. They both still seperate at the rubber/steel union.

Go with the cheaper mount. I'm on my second one, and it'* tearing with only 2k miles on it, but that'* a different story. I'm working on a solid mount alternative for the extreme applications.
willwren is offline   Reply With Quote
Old 08-23-2007, 11:21 AM   #8
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Feb 2005
Location: Toronto, Canada
Posts: 363
Thanks: 0
Thanked 0 Times in 0 Posts
Dutch2005 is on a distinguished road
Default

I called the stealer and my price (trade) is $220, thats insane.

So I called a Delco dealer that I know they had one in stock.
When I went to pick it up I realized that it wasn't Delco but another brand called Corteco I think. It ended up costing me $50.

Is this a good mount or should I return it and go for a different brand ?

Thanks,
Dutch
Dutch2005 is offline   Reply With Quote
Old 08-23-2007, 11:35 AM   #9
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Are you sure you quoted the right mount? Did you LOOK at it to be sure?
willwren is offline   Reply With Quote
Old 08-23-2007, 11:42 AM   #10
Senior Member
True Car Nut
 
Join Date: Aug 2004
Location: In your garage, swipin' da lug nutz
Posts: 3,067
Thanks: 0
Thanked 0 Times in 0 Posts
sandrock is on a distinguished road
Default

Dunno...I can tell you this though....Anchor makes a pretty crappy trans mount. Only two of the three mounting holes would only mate with the trans.

Pioneer, what Don used on his, seems to be a decent piece.
sandrock is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Notes from changing engine mount (really trans mount) GunsOfNavarone 2000-2005 6 05-31-2013 10:45 AM
New Motot Mount Broke in half in less then 1 month???? 99BlackSSEI 1992-1999 4 08-09-2010 02:43 PM
Broken Mount(Now fixed) + No AC Bolt? Lowrider0308 1992-1999 15 08-19-2007 12:36 AM
Suspected Motor mount issue..CONFIRMED!!! BROKEN IN HALF! Hans 2000-2005 26 01-28-2007 03:23 PM
Inner tie rod and broken front left trans mount Kennginn 1992-1999 21 03-02-2004 07:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.