EGR woes - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-04-2012, 08:52 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Sep 2008
Posts: 90
Thanks: 0
Thanked 2 Times in 1 Post
Richardyuyu1 is on a distinguished road
Default EGR woes

I've been trying to fix my sporadic check engine light do to my EGR. The valve works, I changed the plug and I I've removed both tubes from the valve and they're clean no blockages.But I noticed that when I took the tube that runs from the EGR to the upper intake it slipped out pretty easily. Should there be an o-ring around the tube to seal it to the intake?


98 SLE
Richardyuyu1 is offline   Reply With Quote
Old 03-04-2012, 09:03 PM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,645
Thanked 997 Times in 774 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Nope, no o-ring. Though, even a small crack can cause issues.

What are your codes?
Mike is offline   Reply With Quote
Old 03-05-2012, 04:30 AM   #3
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Any cracks anywhere in that flexi-egr tube?

What specific code do you get?
WilliamE is offline   Reply With Quote
Old 03-05-2012, 02:30 PM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

If you say insufficent flow code, take a look at the map.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
EGR low flow. Replaced EGR, still getting code 1997_LeSabre 1992-1999 8 04-20-2005 10:06 AM
1997 4T65E-HD wierd acceleration woes Custom88 1992-1999 5 10-01-2003 08:58 PM
Radiator woes... TiMSmo0th 1987-1991 0 08-07-2003 03:45 PM
ARRRGGHHH! Jet Chip woes! ixlr8 Performance, Brainstorming & Tuning 20 12-16-2002 01:58 PM
Woes and whistles Teuobk 1992-1999 6 12-31-1969 08:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.