Complete power failure - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-19-2004, 07:53 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2003
Posts: 3,684
Thanks: 0
Thanked 0 Times in 0 Posts
smellbird is on a distinguished road
Default Complete power failure

I got a problem! My car randomly will shut down. It'* happened four times now, three times it was just a momentary loss but once it shutdown completely.
A bad ground is my first suspect. Is there any easy way to track it down?
smellbird is offline   Reply With Quote
Old 02-19-2004, 08:14 PM   #2
Senior Member
Posts like a Northstar
 
Join Date: Aug 2003
Location: Buffalo Grove, IL
Posts: 666
Thanks: 0
Thanked 0 Times in 0 Posts
Glasuan is on a distinguished road
Default

Does the power dip all of a sudden?
Glasuan is offline   Reply With Quote
Old 02-19-2004, 10:07 PM   #3
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

I would suspect dirty battery terminals and connectors. Time to clean them all with a wire brush.
fuddyduddy121 is offline   Reply With Quote
Old 02-19-2004, 11:27 PM   #4
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2003
Posts: 3,684
Thanks: 0
Thanked 0 Times in 0 Posts
smellbird is on a distinguished road
Default

I went to start my car to take something to BonneMe and my interior lights just went out.
Well I went to look at my battery teminals just to make sure(I cleaned them when I put my Red Top in) and when I went to loosen the neg. connection and the power came back!
I looked at the terminals and they were clean.
I don't know whats going on but I re-set both the pos. and neg. to make sure there was a good connection.
smellbird is offline   Reply With Quote
Old 02-19-2004, 11:53 PM   #5
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Did you clean the ends of the battery cables, too? You definitely have a bad connection there.
fuddyduddy121 is offline   Reply With Quote
Old 02-20-2004, 12:00 AM   #6
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Or at the other end....check the grounds. Including the connections in the maxifuse relay center.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Complete electrical power loss when driving! EasyE 2000-2005 2 07-04-2008 08:52 PM
Front power window failure seahuntmike Everything Electrical & Electronic 11 03-13-2007 12:49 PM
Power Failure, Need Help bman6020 Everything Electrical & Electronic 6 12-08-2006 07:40 AM
no power to fuel pump, power windows & power seat options13 Everything Electrical & Electronic 11 08-13-2006 02:42 PM
Complete loss of power, Barely wants to move........ LuxuriesPremier 1992-1999 1 07-22-2006 05:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:44 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.