Can my water pump be going bad? - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-02-2005, 07:58 PM   #21
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Jun 2005
Location: Tucson, AZ
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
nick s is on a distinguished road
Default

Quote:
Originally Posted by jr's3800

Nick, let us know how it all goes...
Well I just finished it and all went well with the PS pump, yes mine would drop and not slide. Getting the first 13mm bolt in the hole took me almost as long as removing the WP.
After I got it all together I said to myself that I will never take it apart.
Well I started it and sure enough, if I had didn't have bad luck I wouldn't have any luck at all.....Nope it doesn't leak, it sounds like a Boeing 737 spooling up. The squealing coming from the WP is too excesive. I don't want to take it apart so I guess I am going to find a shop to do it for me, I can't win this week, everything is going the wrong way....
nick s is offline   Reply With Quote
Old 12-02-2005, 08:22 PM   #22
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Jun 2005
Location: Tucson, AZ
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
nick s is on a distinguished road
Default

Can the squealing be a belt issue?
nick s is offline   Reply With Quote
Old 12-04-2005, 10:40 AM   #23
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Jun 2005
Location: Tucson, AZ
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
nick s is on a distinguished road
Default

the squealing has gotten quieter.
No idea what it is or where it is comming from for sure.
I did the old test (place in ear and other end on motor parts) with a 2 foot socket extension and checked for sounds. The noise doesn't sound like it is originating in the waterpump but it sounds like it is from the tension arm.
The alt has a very slight, almost unnoticable squeal coming from it.
I guess I will leave everything alone and see what happens......
nick s is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Water, Water. Water !!!! da_grey_goose_95 Detailing & Appearance 6 02-19-2010 12:36 PM
replaced water pump found some oil in the water pump cavity cjpenny89 1992-1999 3 09-13-2006 12:15 PM
Water Water ... now what? ongoing saga of bad mechanic haughty 1992-1999 14 06-28-2006 06:49 PM
Water Leak around the water pump! BigAl 1992-1999 20 01-28-2003 01:38 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.