Boyfriend made a booboo??? acceleration sluggish - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-17-2009, 11:10 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
KATIEJAMES is on a distinguished road
Cool Boyfriend made a booboo??? acceleration sluggish

Ok a few things... I have a 92 non supercharged bonnie. I am always traveling at 40+mph So I have always diven it in (Over-drive). Today for no reason my boyfriend was drove the car in (Drive) for the first time, for about mile or so, Then car started to run funny, Almost felt like it wasnt getting gas at times. I checked and seen that he was in drive and I check the gauges and they were normal but the when in park the oil gauge would flicker back in forth in place. We manage to make it up the street to our house and I went under the hood and noticed there was coolent coming out from the resavior. (overheated) I let the car cool thinking the he had over heated it.
Drove it after an hour or so and it was fine. Then had to take my nieces home 5miles away and on my way back immedatly after I pushed on the gas pedal to get onto the freeway and it started to run sluggish again Like she was about to die But never did.
Once I got up to 55mph no problem, It happends only when I have to start moving again. So I nursed it home. And now she sits.

There is so many things it could be.

I love him dearly but,,,,,,, Could my bone headed boyfriend have cause this.
or ,,, wait,,,,,Any clue what it sounds like it could be. Where should I start?


1)Oil gauge flickering back and forth in place while in park
2)coolent spray under hood.
3) accelerating slugglishly
oh,,,, and theres was a constant ticking noise while we waited,, Now I was told last year when I had that noise that it had something to do with my Ac. The Ac got unplugged and I was told if if still made that noise I had to repair that part.. lol I have no idea what it was... Hope that helps any

Im going to get a new fuel filter tomarrow. Anything else? If It was overheating wouldnt I have seen It on my gauge something?? Please help,,,, I need to fix her before Monday Thanks you guys dont know what I would do with out ya

Last edited by KATIEJAMES; 04-17-2009 at 11:20 PM.
KATIEJAMES is offline   Reply With Quote
Old 04-17-2009, 11:51 PM   #2
Senior Member
Posts like a 4 Banger
 
Join Date: Sep 2008
Location: orlando fl
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
BADBUICK is on a distinguished road
Default

so so many thing i think your bf was just wrong place wrong time. but to clarify he was in drive or overdrive? how fast was he going? i think fuel filter sounds most liekly fuel pump etc. tune up etc... i think the best next step would be to pull a plug see if there is coolant in the engine, you can also tell if its been running lean( very white) rich(very dark) they should be a nice tan color.
BADBUICK is offline   Reply With Quote
Old 04-18-2009, 12:22 AM   #3
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Pull the plugs and inspect. Post pictures if you can. I don't think your BF did anything. The difference in RPM isn't enough to cause damage while driving normal.
Danthurs is offline   Reply With Quote
Old 04-18-2009, 12:22 AM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Mar 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
KATIEJAMES is on a distinguished road
Default

Thank you for the reply. He was going 40mph in Drive.
I will take a look and see if she running lean or rich. I hope its not the fuel pump. I will also check the plugs I will try to post pics

Last edited by KATIEJAMES; 04-18-2009 at 12:24 AM.
KATIEJAMES is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Just made a BooBoo! raptor660 Audio (and aftermarket electronics) 1 01-15-2011 05:35 AM
95 SE Still has sluggish acceleration WeaD 1992-1999 5 04-16-2009 05:07 PM
sluggish acceleration David CO 2000-2005 4 07-05-2006 01:48 AM
Strange noise accompanied by sluggish acceleration davinci_360 1987-1991 8 10-29-2005 12:57 AM
SLUGGISH ACCELERATION & CHECK ENGINE LIGHT BLINKING 98' nathem 1992-1999 5 06-08-2005 01:18 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.