Bonny buddies - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-26-2003, 12:16 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default Bonny buddies

I have '97 Bonneville SE for more than 3 years and was wondering all the time that I'm the only one who loves this car so much. Now, when my Bonny got sick and doctors are sending big bills for treatment, I had no other choice as to look for the help and answers on the Web. To my surprise I have found a whole bunch of people who are devoted to their Bonnies and willing to help others. I'm very pleased with web site and finding myself at Home.
Boris is offline   Reply With Quote
Old 02-26-2003, 12:19 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Boris, where are you from (I have a guess) and what ails your car?
willwren is offline   Reply With Quote
Old 02-26-2003, 01:09 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default

I lived in New York for a 5 years and just moved to New Jersey. This is my second car in States and I was so proud of it at the begining. Now it'* very sick and I put so much money that I'm loosing my trust in it and mechanics.
It'* all started on a one day when it suddenly "choked" and sort of lost a power. The car wouldn't allow me to quickly change the gears and I had to slightly push the pedal to climb to 2500 prm. If I would press it harder it would choke again. In a day or so check engine light appeared. The mechanics in Brooklyn put the car on diagnostic but couldn't come up with anything else then to do full tune-up. When I got a car back it was better ,but in 3 weeks it choked again and that time it looked like I was running on 5 cilinders. I got a car back into shop and actually found miself that one of the high voltage cables is sparkling. After cable was replaced car ran for about 6 month with different problems.
So here goes the list:
1.Car feels heavy and pedal feels heavy. When I push the pedal I can hear the revs but the car is not going anywhere ( too slow). This is a sporadic problem. Another day it can fly.
2.The whole car is shacking on the speed from 50-100 mph. Brake pedal pulsating and steering wheel shacking when I apply brakes at these speeds.
3.Coolant is gone and I can smell it when engine is hot.
4.There is no oil leak , but car eats 1 liter a week.
5.Check engine light is on
6.When transmission pan was droped , transmission oil was so stinky that the whole place turned their heads toward my car.
The day before yesterday got the car from Midas. I dropped them 2300$
Here what they've changed:
1.Lover and upper Intake manifold and gasket
2.O2 sensor
3. Water pump
4.Some coolant hoses
5.195 termostat
6.Left hub bearing
7. Both Rotors and new metallic pads on front.
Yesterday I was tesing car and today brought it back with this:
1.Check engine light is back
2.Car is whole shacky and feels loose.
3.There is a knock when turning wheels to the right and then to the left.
4.Smell of oil and coolant when engine is hot.
5.Loss of power again and increased temperature ( was good for a day )
6.When in idle oil level on gauge is normal and when on "drive" going closer to a low redline and batery charge arrow is shaking.
7.Level of oils and coolant is ok.

So, I'm waiting for them to come up with some new problem and another big $ number which I can't afford at this time.
What to do, I don't know. I love my car and was maintain it very well. But it sounds like I gotta learn more to maintain it better.
Please help !!!
Boris is offline   Reply With Quote
Old 02-26-2003, 12:50 PM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by Boris
Yesterday I was tesing car and today brought it back with this:
1.Check engine light is back
Okay, the _very_ first thing to do is to get the stored error codes out of the computer to find out what it is complaining about.

Quote:
Originally Posted by Boris
2.Car is whole shacky and feels loose.
3.There is a knock when turning wheels to the right and then to the left.
Someone needs to look at the struts and suspension up front. They should also torque the wheel lug nuts by hand, not use an impact wrench, to avoid warping the rotors. (I think this has already happened on your car, and I think you said you had new rotors now anyway, but re-torquing by hand might relax some of the stress and future warping.)

Quote:
Originally Posted by Boris
4.Smell of oil and coolant when engine is hot.
5.Loss of power again and increased temperature ( was good for a day )
I hate to say this but it sounds like a head gasket has gone bad again...?

Quote:
Originally Posted by Boris
6.When in idle oil level on gauge is normal and when on "drive" going closer to a low redline and batery charge arrow is shaking.
Oil pressure will drop when the engine'* hot. Battery voltage should not fall unless the alternator is going bad on you.

Frankly, this engine sounds like it'* got problems, and the repair guys are just throwing (your) money at it instead of sitting down and examining the engine first to see exactly what it needs.
acg_ssei is offline   Reply With Quote
Old 02-26-2003, 03:06 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default

The symptoms with oil dropping pressure is new to me and happend a day after I took the car from repair.Like I said an engine performed very well for more than a day after repair was done. Temperature was even below level when I drove a car first time back in 1999. And all of a sudden temperature climbed, oil pressure low and no power.
I'm waiting on Midas to come back with new details and their findings. Thats going to be interesting....
Boris is offline   Reply With Quote
Old 02-27-2003, 01:20 PM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default

Ok...got reply from Midas. They haven't found anything wrong with a car. I have spoken to manager only, because mechanic wasn't there. He implies that Oil presure is 80 ( I assume psi) and that is normal. I told him that I've seen pressure dropping on the oil gage when car is hot and the shift stick in the drive position.
His explanation of engine light was that PCM computer is bad and I gotta go to dealer to scan and reprogram it. I don't know what the hell he is talking about.
They also didn't find any problems with brake and knocking, so on that I said that I want to put the guy next to me and give him a ride.
Any suggestions?
Boris is offline   Reply With Quote
Old 02-27-2003, 03:41 PM   #7
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by Boris
His explanation of engine light was that PCM computer is bad and I gotta go to dealer to scan and reprogram it. I don't know what the hell he is talking about.
Oh, bologna. I think they either did not bother to scan it for error codes, or do not know how to do so in the first place.

I know you have spent a ton of money with these guys but I am thinking it might be better for you to cut your losses and try someplace else. Have any friends who can recommend a better repair place for your car?
acg_ssei is offline   Reply With Quote
Old 02-27-2003, 04:12 PM   #8
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default

Unfortunately I don't have friends who would recomend a good mechanic to me. For the past 1year I have been to a different shops at least 12 times. Changing caliper,rotors (3 times), breaks, tune-ups, diagnostics, sensors, gaskets, tensioner and so on. I hate when someone is BS me. I couldn't come up with anything less as starting to learn on my on. I don't know if I ever be able to repair anything on my own, but considering what I've spent - it couldn't be worse.

What scan tool I can use to determine the problem with check engine on my own. I saw they were using Snap-on (I think). I'm a sr.system analyst , so I believe I'll be able to figure out how to use it.
Boris is offline   Reply With Quote
Old 02-27-2003, 04:29 PM   #9
Senior Member
Expert Gearhead
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

There are a few guys who have scan tools, the one that comes to mind immediately is willwren, I think jrs3800 has one as well.

I'm getting one, they are very good to have. Its a good plan to get one!
Jim W is offline   Reply With Quote
Old 02-27-2003, 05:58 PM   #10
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2003
Location: New Jersey
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Boris is on a distinguished road
Default

So what tool should I get? And will I be able to tell if PCM or other electric parts are bad. I've heard that PCM can behave funky sometimes, but very rare.
Around 6 month ago I already had diagnostic for 3 days (the problem was bad wire) That time module tested and appeared to be good. With all the simptoms that I've described before coould it be a electric problem?
Should I go to dealer for diagnostics or try on my own. Another words - can I trust a dealer?
Boris is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ghetto buddies Unite. james tharp Lounge 11 06-28-2005 12:53 AM
Any GM Mech's? Buddies S10 Service Engine soon @ 50k miles givemebreak Lounge 2 04-19-2004 05:53 PM
Check out my buddies site, One INCREDIBLE Pencil Artist! givemebreak Lounge 2 04-18-2004 07:12 PM
My buddies Porsche DrJay Lounge 3 02-22-2004 10:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:59 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.