Battery problems - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-08-2003, 05:32 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2002
Location: Greenville, SC
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Wolfedog50 is on a distinguished road
Default Battery problems

Ok. Here'* the deal. My battery and battey cable are wicked corroded. I found this out after my car wouldn't start. Now i got them cleaned and back on, but the car still only starts sometimes. I need new cables, but i can't seem to find any. anyone have any idea where i can get some
Wolfedog50 is offline   Reply With Quote
Old 09-08-2003, 05:40 PM   #2
Junior Member
 
Join Date: May 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
SSEi95 is on a distinguished road
Default

I had similar problems a while ago and it turned out to be a bad battery. Something like the posts were no longer firmly connected inside of it. I had cleaned off and securily attached the cables and still had issues.
SSEi95 is offline   Reply With Quote
Old 09-08-2003, 05:40 PM   #3
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I can get you the stock GM part numbers, but it'll have to wait til tomorrow. My magic book is at home, and my home PC just took a major dump today.....so I'll have to reply with the numbers from work tomorrow.
willwren is offline   Reply With Quote
Old 09-08-2003, 06:32 PM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default Re: Battery problems

Quote:
Originally Posted by Wolfedog50
Ok. Here'* the deal. My battery and battey cable are wicked corroded. I found this out after my car wouldn't start. Now i got them cleaned and back on, but the car still only starts sometimes.
If you didn't pop the little bolts out of the molded rings on the end of the battery cables, you probably missed a large area of corrosion under the heads of the bolts, where they make contact with the metal rings of the cables. Maybe a little more cleaning will help there.

Also check the _other_ end of each cable, especially down at the starter solenoid as well as the ground connections to the block.
acg_ssei is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Any issues replacing a battery with 550 CCA with a 800 CCA battery GunsOfNavarone General GM Chat 8 10-06-2014 08:17 AM
ohh battery ohh battery (kinda long) TISbonneville General GM Chat 2 03-04-2006 04:48 AM
Problems, Problems, Problems... swartlkk 2000-2005 2 11-04-2005 08:57 PM
Problems with something battery related Vaughan221 Everything Electrical & Electronic 16 10-05-2004 03:05 PM
problems, problems, problems big_boss2010 1992-1999 15 04-25-2004 09:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.