Bad tranny solenoid? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-15-2004, 03:21 PM   #1
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default Bad tranny solenoid?

I hooked up my scan tool today and found out that as soon as i put the car in reverse, QDM AS goes bad and it stays like that through nuetral and OD, and then when after i put it in OD, QDM B goes bad too and sometimes QDM A will be good again. What can be causing this, and would a tune up fix them? thanx
jachin is offline   Reply With Quote
Old 09-15-2004, 03:28 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default Re: Bad tranny silenoid?

Quote:
Originally Posted by jachin
I hooked up my scan tool today and found out that as soon as i put the car in reverse, QDM AS goes bad and it stays like that through nuetral and OD, and then when after i put it in OD, QDM B goes bad too and sometimes QDM A will be good again. What can be causing this, and would a tune up fix them? thanx
There'* a bug in the firmware of your scantool. I think you'll find that as soon as you depress the brake pedal (the first step before selecting a gear), the QDMA line will go bad. That'* normal if it acts that way. jr's3800 and I have both observed this.

The QDM B fault has me curious though. Can you check the status of the P/N safety switch, and verify that each gear shifts as it'* supposed to, and the TC locks up on OD above 48mph.

No codes I assume?
willwren is offline   Reply With Quote
Old 09-15-2004, 04:01 PM   #3
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

I dont think the TCC would have anything to do with it Because it throws the code as soon as i put it in gear, before its anywhere near engaging. Ill pay attention to the shifts on my way to work today, but as far as i know it shifts fine, besides being a little rough at WOT in performance shift. When i did my tranny fluid change a few months back, the liquid was dark, but there werent any shavings or anything. ITs still throwing the QDM B fault
jachin is offline   Reply With Quote
Old 09-15-2004, 04:06 PM   #4
Senior Member
Posts like a Camaro
 
Join Date: Jan 2004
Posts: 1,166
Thanks: 0
Thanked 1 Time in 1 Post
mkaake is on a distinguished road
Default

it'* a good thing you didn't see any shavings, as there'* a magnet in the pan to keep those from ever getting anywhere important

if the solenoid was really bad, you would prolly be stuck with about 2 gears. not too familiar with the scan tool codes though, so I'll just let will duck his head back in...
mkaake is offline   Reply With Quote
Old 09-16-2004, 03:09 PM   #5
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

IT shifts from 1 to 2 at 20 and from 2 to 3 at 35 under normal driving conditions. And the torque converter seems to lock up around 48. What else could this be?
jachin is offline   Reply With Quote
Old 09-16-2004, 03:27 PM   #6
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Clear the codes and let'* go back to the beginning, but ignore the QDM fault that toggles with the brake pedal.
willwren is offline   Reply With Quote
Old 12-12-2004, 12:47 PM   #7
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

sorry about the long wait, i know im lazy and i seem to only do things when its convenient for me. anyway, in drive, the tcc locks up at about 48 and in od it locks up a few miles over that. When i scaned it today i found that qdm B is good in park, then goes bad in reverse, then is good again through OD. Any idea what this could be
jachin is offline   Reply With Quote
Old 12-12-2004, 12:56 PM   #8
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Set the parking brake, chock the wheels both front and rear with bricks, and try that again without the foot on the brake.

Any drivability issues that you notice? Any corrosion on the Trans harness connector?
willwren is offline   Reply With Quote
Old 12-12-2004, 01:12 PM   #9
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

It wouldnt let me take it out of park with the parking brake engaged and my foot on the brake pedal. It still did the same thing, it didnt go bad when i pressed the brake, it went bad whenever it went in reverse. Could my afc have something to do with this, i have heard that it can change the way the trans acts, maybe they forgot to include some kind of programing or something when they made it for reverse
jachin is offline   Reply With Quote
Old 12-12-2004, 01:43 PM   #10
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

Well i just got back from a test run and the scan tool is telling me something entirely different. Its telling me that it isnt even engaging its doing nothing at all according to the scan tool, but whenever i stomp the pedal, i hear the motor rev up for a second and then the tcc engages and it pulls like nothing is wrong. This almost has to be some kind of electrical failure right?
jachin is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
92 Bonnevile, bad TCC solenoid? AlphaOne 1992-1999 7 02-18-2005 11:04 AM
BAD one liners. Bad, really really bad, but still funny. BonnieBrougham Lounge 3 12-16-2004 06:38 PM
Tranny clunk and tranny slippage nething to worry about look killer_cr80r Lounge 4 04-20-2004 01:00 PM
Please read. Tranny problems with a newer tranny? bonnie94ssei General GM Chat 7 11-03-2003 02:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.