Backfiring when starting, will barely run - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-28-2007, 09:44 PM   #11
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: East Hartford, CT
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
chuckt is on a distinguished road
Default

This hole process lasts about 3 seconds, is that enough time to scan it? Could the coils actually cause it to race like that? It did pop once and it popped the vacuum-tee right out of the top of the manifold. I'm really lost on this one........ :(
chuckt is offline   Reply With Quote
Old 11-28-2007, 10:00 PM   #12
Senior Member
Certified GM nut
 
Join Date: Oct 2006
Location: burb of detroit. 2 miles north of 8 mile Rd.
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
samueljackson is on a distinguished road
Default

as far as a trouble code, it doesnt matter how long the eng runs, the ecu will store the dtc if it trips one, in that 3 seconds. just scan it with key on , eng off.
samueljackson is offline   Reply With Quote
Old 11-29-2007, 10:22 AM   #13
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: East Hartford, CT
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
chuckt is on a distinguished road
Default

The ICM came out of an 06 GM product. Everything looks the same, but is it really. Its funny how the symptoms changed with this ICM. Any thoughts??
chuckt is offline   Reply With Quote
Old 11-29-2007, 11:08 AM   #14
Senior Member
Certified GM nut
 
Join Date: Feb 2004
Location: CT
Posts: 2,099
Thanks: 0
Thanked 1 Time in 1 Post
SSEBONNE4EVA is on a distinguished road
Default ICM

look up both ICM part numbers on www.acdelco.com and see if they are the same. 06 would be a series III fly by wire motor. I doubt they are the same. You need one from a 95 and under motor.
On a previous post you mentioned a bad cell in the battery. Have you resolved this?
SSEBONNE4EVA is offline   Reply With Quote
Old 11-29-2007, 05:35 PM   #15
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: East Hartford, CT
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
chuckt is on a distinguished road
Default

I did resolve the bad cell issue, bought a new batttery. I will check the part numbers like suggested. Curious point you make on the year of the ICM. The yards in CT dont list anything under ICM but they list them by coil. (Checked car-part.com) I am sure all the coils are the same but it seems weird the ICM would be. It popped hard enough to blow the vacuum t out of the top of the manifold last night.

Just checked acdelco.com and what do you know it fits GM cars all the way up to 2008. Its still weird though, I changed the icm and now I have new symptoms. Maybe I'll try to put the old ICM in.
chuckt is offline   Reply With Quote
Old 11-29-2007, 11:01 PM   #16
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2007
Location: East Hartford, CT
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
chuckt is on a distinguished road
Default

Put back in the old ICM with the newer coils and bang, shes running good! Just wanted to close out the post.

Many thanks to those who helped!
chuckt is offline   Reply With Quote
Old 11-30-2007, 11:28 PM   #17
Senior Member
Certified GM nut
 
Join Date: Oct 2006
Location: burb of detroit. 2 miles north of 8 mile Rd.
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
samueljackson is on a distinguished road
Default

Quote:
Originally Posted by chuckt
Put back in the old ICM with the newer coils and bang, shes running good! Just wanted to close out the post.

Many thanks to those who helped!
thats cool, glad it runnin like it should
samueljackson is offline   Reply With Quote
Old 12-01-2007, 12:53 AM   #18
Junior Member
 
Join Date: Jun 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
2000SilverBullet is on a distinguished road
Default

classic case of too much choke with the cold temps running now.

What year do you have?
2000SilverBullet is offline   Reply With Quote
Old 12-01-2007, 12:54 AM   #19
Senior Member
Certified GM nut
 
Join Date: Oct 2006
Location: burb of detroit. 2 miles north of 8 mile Rd.
Posts: 2,028
Thanks: 0
Thanked 0 Times in 0 Posts
samueljackson is on a distinguished road
Default

he has a 93
samueljackson is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Poor idle, backfiring, no power jaye22 1992-1999 2 05-05-2006 04:42 PM
backfiring problem zepployd44 1992-1999 4 05-03-2006 12:15 PM
1989 backfiring and stalling when engine is hot?? jaswasup 1987-1991 8 11-13-2004 12:53 PM
Faulty Injectors/Fuel system & backfiring... bonnie94ssei General GM Chat 4 02-06-2004 09:43 PM
Backfiring? Tubby 1992-1999 3 07-07-2003 06:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.