Backfiring? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-05-2009, 09:55 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default Backfiring?

turns out i found out where the fuel smell is coming from after stepping out ... the air filter box
giving her shots of gas this sucker backfires....could it be timing? valves? too rich?
im gonna drive this green piece of **** into a tree waisting to much $$$ on this car
Geforce is offline   Reply With Quote
Old 06-06-2009, 01:18 AM   #2
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

If you are backfiring through the TB, you have a timing issue or a throttle body position sensor that is bad. Test the sensor first then worry about timing if the sensor is okay https://www.gmforum.com/t279319/
Purplehazeir is offline   Reply With Quote
Old 06-06-2009, 05:43 PM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default

huh didnt see that coming... ill test the sensor and see if its still operational.
BTW doesnt backfire when i drive her only when shes at park and giving her quick pumps of gas
Geforce is offline   Reply With Quote
Old 06-06-2009, 06:48 PM   #4
Senior Member
Posts like a Turbo
Thread Starter
 
Geforce's Avatar
 
Join Date: Dec 2008
Location: Mississauga Ontario
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Geforce is on a distinguished road
Default

forgot to mention can the TP sensor cause low RPM upshifts.. e.g cruising or climbing speed slowly it upshifts and wont downshift unless i let of the gas
Geforce is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Poor idle, backfiring, no power jaye22 1992-1999 2 05-05-2006 04:42 PM
backfiring problem zepployd44 1992-1999 4 05-03-2006 12:15 PM
1989 backfiring and stalling when engine is hot?? jaswasup 1987-1991 8 11-13-2004 12:53 PM
Faulty Injectors/Fuel system & backfiring... bonnie94ssei General GM Chat 4 02-06-2004 09:43 PM
Backfiring? Tubby 1992-1999 3 07-07-2003 06:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.