95 SSEi several problems, throwing QDM codes - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-28-2011, 04:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
89TurboGP is on a distinguished road
Default 95 SSEi several problems, throwing QDM codes

I just bought a 95 Bonneville SSEi earlier this week as my new driver. The car ran perfect when I bought it, no issues at all. The other day i went to leave work and had the following problems:
Speedometer and the speed in the HUD are not working
High idle, around 500rpm higher then it should be.
Check engine light on
Traction Off light on and traction button does not work.

I had it on a scan tool today and it'* throwing all 3 QDM codes.
P1640: Boost control, EVAP purge and TCC solenoid
P1650: Shift and TCC solenoids
P1670: A/C relay and Fan relays

None of these seem to have anything to do with the speedometer or traction control. Im thinking maybe a bad ECM? Ideas?
89TurboGP is offline   Reply With Quote
Old 08-29-2011, 07:55 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

the vss and a few of those things could use the same fuse and power wire i would start by investigating that
jwfirebird is offline   Reply With Quote
Old 08-29-2011, 08:28 AM   #3
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,854
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

There is also ground busses under the floor. If those get corroded, which is known to happen, stuff doesn't ground. I would be inclined to check those. I believe they are just in front of the front doors, just under the carpet. There is for sure one on the drivers side, and I believe one on the passenger side as well.
rjolly87 is offline   Reply With Quote
Old 08-29-2011, 08:41 AM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

fuse 5 has the o2, evap, boost control, egr, and some going to the trans, and ecm pin A15. according to my diagram it should be a pink wire
jwfirebird is offline   Reply With Quote
Old 08-29-2011, 11:18 PM   #5
Junior Member
Thread Starter
 
Join Date: Aug 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
89TurboGP is on a distinguished road
Default

I will check more into the wiring. I looked over all of the relays and harnesses in the fuse/relay center under the hood. I need to check the harness going through the firewall to the ECM. Fuses are all good, checked all of them inside the car and under the hood.
89TurboGP is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Several Questions/Problems 93 SSEI Rough Idle/Fuel Pressure Knight-Design 1992-1999 21 09-02-2010 04:00 PM
GTP throwing codes: P1651, P1652 JimmyFloyd Pontiac 6 03-29-2007 04:52 PM
several SES codes 26, 34, 63 yttaf 1987-1991 0 07-11-2006 09:01 PM
car is throwing codes. Pontiac1983 1992-1999 5 11-01-2003 02:01 AM
92 ssei, Computer keeps throwing codes bigred 1992-1999 10 10-06-2003 09:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:26 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.