95 Bonneville with starting/ running issues - Page 5 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-19-2013, 10:49 PM   #41
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Ok, so are they both connected now or not yet?

BTW, you forgot...

MealReadytoEat...MRE.
Mike is offline   Reply With Quote
Old 12-19-2013, 11:32 PM   #42
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2013
Location: Sacramento, CA
Posts: 70
Thanked 2 Times in 1 Post
Mealticket is on a distinguished road
Default

The rear is most likely disconnected; I can see a connector hanging down but wasn't sweating it...live and learn. I'll look tomorrow am. Re: the front, it was hanging down too, but a few days ago I squared that one away. I believe this engine was swapped in, and I'm starting to notice some sloppy stuff. Also my new serpentine belt is already rubbing weird, I believe due to incorrect spacing on the one alternator mount point. I may have to deal with that before I even take it back for smog, assuming I solve the CEL.

One good thing from today; smog guy printed out a wiring diagram, and I see that the fuel pump relay and the power in to the ignition module use a common relay, and those are both hotwired on this car. WHEN it smogs, I will square that away. That relay is shown at 'rear relay center E'. Know where that is? I assumed that underhood relay center but I guess not? Yes...

MealMeSoonPlease
Mealticket is offline   Reply With Quote
Old 12-19-2013, 11:35 PM   #43
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

No, fuel relay is in the passenger side kick panel center.
Mike is offline   Reply With Quote
Old 12-20-2013, 12:12 PM   #44
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2013
Location: Sacramento, CA
Posts: 70
Thanked 2 Times in 1 Post
Mealticket is on a distinguished road
Default

On my way to look at rear knock sensor, but just confirmed on Autozone that the knock sensor is '95 only, and the front one on my car appears to be a later year. I had to splice on a different connector to get the front one connected earlier in the week. I'm betting the rear is the same, and that'* why they didn't connect them. So if I can't plug in the rear I'll try running a jumper and see if that puts out the CEL. Wonder if the different sensors are compatible. I know somebody said '95 had some unique sensors...

MealMaybeClose
Mealticket is offline   Reply With Quote
Old 12-20-2013, 12:46 PM   #45
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2013
Location: Sacramento, CA
Posts: 70
Thanked 2 Times in 1 Post
Mealticket is on a distinguished road
Default

I'm betting ECT is wrong too. Suspected something there for awhile, because the housing on it is missing a chunk. Probably the connectors are different and they damaged it pushing the connector on. Hope they didn't put a different year tranny in it. That would mean no meal ever again...

Meal????????
Mealticket is offline   Reply With Quote
Old 12-20-2013, 01:10 PM   #46
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2013
Location: Sacramento, CA
Posts: 70
Thanked 2 Times in 1 Post
Mealticket is on a distinguished road
Default

In terms of tranny/PCM compatibility, anybody know real quick what I should look at if this is a different year tranny? Where can I look for numbers to ID this?

MealLessLikely
Mealticket is offline   Reply With Quote
Old 12-20-2013, 01:37 PM   #47
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

According to Rockauto.com
ACDelco temp sensor part #213815 1995-1999
Knock sensor is 1995 ONLY.
TPS sensor is 1995-2005-Very common
IAC 1995-2005
EGR valve is 1995-2001
Camshaft sensor has 2 different part #'* and are a different year range.
Crankshaft sensor same thing, 2 different part #'*, but its the full year range of 1995-2005

Did you keep your original MAF sensor or did you swap it out also?
That'* 1992-1996.

ICM is 1992-2005.

And it doesn't matter what platform of vehicles that engine came from either. Buick, Chevrolet etc. The sensors must match the receiving vehicle.
Mike is offline   Reply With Quote
Old 12-20-2013, 01:39 PM   #48
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

This is how you identify your trans make/model.

Mike is offline   Reply With Quote
Old 12-20-2013, 01:40 PM   #49
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I think 1995 to like 1998 or so the trans are all the same except for the FD and the electrical connector. But don't quote me on the year range.
Mike is offline   Reply With Quote
Old 12-20-2013, 08:57 PM   #50
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Dec 2013
Location: Sacramento, CA
Posts: 70
Thanked 2 Times in 1 Post
Mealticket is on a distinguished road
Default

Thanks, Mike. I will definitely ID that tranny. What is FD? And how do I find out the year of the engine? Yeah; knock sensor is definitely '95 only; connector for it is different. Today I spliced a later connector on my wire to the rear sensor to see if that would put the CEL out; it did not. In fact, it seemed to run worse than before once the light came on. It does seem to take longer for the CEL to come on now after clearing.

Hmm...it seems there are some conflicts on the interchange depending on which source you use. Autozone shows the ECT as different between '95 and '96; I will swap mine just to be sure, especially since it has a crack in the plastic housing. I'm showing more interchange on the cam sensor than you. Tomorrow I will also get the '95 knock sensors and I'll start with those and the ECT. I don't know if they swapped the MAF; the P/N is 1228645000115505. I have not been able to cross that to anything yet. The guy I bought the car from seems willing to share info; waiting on that.

I just bounced this all off the tech and he actually thinks it'* something totally disconnected, rather than a part incompatibility. I'm not sure I agree, but he'* been doing this 30 years. The last time I doubted him he made me look quite stupid. I looked pretty close today, and other than some idiot forcing wrong A/C plugs into sockets, I don't see anything else,

Mealnogle
Mealticket is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
intermittent weird starting/not starting.... HELP!! jaye22 Everything Electrical & Electronic 15 04-14-2017 08:10 PM
90' Bonneville SE warm starting issues zachmichener 1987-1991 1 01-01-2011 08:06 PM
running/starting issues 92bonne 1992-1999 3 12-09-2006 12:19 PM
Non starting/ running issues etc. 1992-1999 9 09-11-2006 10:41 PM
Trouble with starting/running '95 supercharged 3800 fatfenders 1992-1999 3 05-27-2003 09:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.