94 bonne elecronic climate control problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-01-2009, 07:50 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
nightriderr is on a distinguished road
Unhappy 94 bonne elecronic climate control problem

The electronic climate control in my 94 bonneville ssei is blinking the temp # and is blowing nothing but cold air. We just rebuilt the tranny and now this. Has anyone ever had tis happen to them? Is there a trouble code system with this control? How do you access these codes? Please Help!!!!
nightriderr
nightriderr is offline   Reply With Quote
Old 02-01-2009, 08:38 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I'm not all that familiar with that year, but isn't that a vac controlled system? Is it possible you knocked a vac line off?
Danthurs is offline   Reply With Quote
Old 02-01-2009, 09:30 PM   #3
Senior Member
Posts like a 4 Banger
 
Join Date: Dec 2008
Posts: 107
Thanks: 0
Thanked 0 Times in 0 Posts
Downeasta is on a distinguished road
Default

I believe it is all electronic(at least the digital climate control) Behind mine is all wires. I'm in the same situation as you Nightriderr, except mine is just showing 3 dashes instead of flashing the temp.
Downeasta is offline   Reply With Quote
Old 02-01-2009, 09:42 PM   #4
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

you probably disconnected the battery cable to install the transmission. in turn you broke your air mix actuator when you reconnected the cable and turned on the car.
this happens a lot to older Bonneville'*.

in short...check your obvious make sure your engine has coolant....I'm sure you did.
open glove box. remove glove box liner. look through whole on left. now move your temp control all the way to heat and back to cold. does the arm move? if not than pop up the blend door rod arm off the
actuator. move arm left to right. if it allows you to do this than your air mix gear is just broken.
leave it disconnected so you will have heat.

do a search here for: air mix... actuator....gear broken
Toddster is offline   Reply With Quote
Old 02-01-2009, 09:46 PM   #5
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Quote:
Originally Posted by nightriderr View Post
The electronic climate control in my 94 bonneville ssei is blinking the temp # and is blowing nothing but cold air. We just rebuilt the tranny and now this. Has anyone ever had tis happen to them? Is there a trouble code system with this control? How do you access these codes? Please Help!!!!
nightriderr
yes to many of us have had this happen to us, only the few lucky ones have not..so far.

and PM sent for information on your other question.

check your user CP for my response!
Toddster is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2001 SSEi Automatic Climate Control - Blower Control Module andereck 2000-2005 3 08-10-2006 11:58 PM
Climate Control unit is problem is [email protected]@@@@ nick s 1992-1999 37 08-08-2005 10:26 PM
94 sse climate control problem GAMEOVER 1992-1999 5 08-25-2004 01:46 PM
98 electronic climate control problem 98SSE 1992-1999 2 08-02-2004 10:12 PM
Electronic Climate Control display problem -- No, this one's bigred 1992-1999 9 10-01-2003 02:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:32 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.