94 bonne cam/crank ecm? Help please! - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-13-2006, 04:10 PM   #21
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Sep 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
t_j303 is on a distinguished road
Default

So far i've had the cam sensor, crank position sensor, harmonic balancer, a pulley of somesort, the ICM replaced. The vaccuum helped for a little while but it'* still doing the same things. It must be the computer. Very frustrated over $700 in repairs and NO FIX!!! HELP.
t_j303 is offline   Reply With Quote
Old 09-13-2006, 07:59 PM   #22
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

I'd be tempted to try the PCM...

Did you buy all of these items new?

I have been through 2 PCM'*... The 94-95 PCM'* suck hardcore

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 09-23-2006, 01:37 PM   #23
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Sep 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
t_j303 is on a distinguished road
Default

I got all the parts new except the ICM, i had the ECM put in monday and that seemed to do the trick. That was used part also. Now leaking oil. It never ends!!!!
t_j303 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 bonne crank,no start, no power to windows and interior lights. Please Help!!! redwolf 1992-1999 1 11-08-2010 05:44 PM
HELP! cam sensor error... and its NOT the cam sensor Sprig Everything Electrical & Electronic 3 06-17-2006 11:13 AM
Help please tell me where crank&cam sensor are located REDSTU1 1987-1991 2 01-02-2006 07:33 AM
Will not crank since jump start, fried ECM? Pepboys has car. srgetz 1992-1999 13 02-02-2005 10:42 PM
Crank/Cam sensor...cost's at shop leadnbrass 1992-1999 4 07-24-2003 09:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.