2000 SSEi Elec probs - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-01-2002, 03:31 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2002
Location: Wisconsin
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
PaulyB is on a distinguished road
Default 2000 SSEi Elec probs

Looking for Ideas before I start testing and tearing into this thing.

Here a list of a few problems I'm having.

Speedometer, Tachometer, Odometer/Trip, Cruise Control, Turn Signals = not working.

HUD does display speed but not on Dash...

The normal "cool" jump of all the gauges to the opposite end of the gauges all work except for the tach and the spedo. Any ideas. I havent really investigated tons.

For the Cruise Control...im sure it runs of the dash speed or tach. From what i can see its not disconnected...I checked the cruise control module in the engine bay...all wires connected and the cable is fine also...followed it as far as I could.

Hazards do work just not turn signals/ checked all fuses I can think of. The turn signal might be a lose wire or something..strange part is that i replaced the 15 amp fuse (hazard/turn fuse) with a new one just for giggles, then the hazards wouldnt work, tried a second 15 amp, still wouldnt work...then i tried the original...hazards work?

My DIC will not let me do anything...gives warning for tire pressure, and calibrate compass. I cannot go into any mode fuctions (is this normal when tire warn is going off?) wont let me reset tire by pressing mode blah blah. All tire pressure looks fine and within 1 psi from what my crappy gauge tells me

Im thinking of just discon. Batt for a short period of time and seeing what happens. Just all the elec probs scare me a tad. Any help/Advice would be appreciated!

Thanks!
PaulyB is offline   Reply With Quote
Old 10-01-2002, 03:36 AM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Your battery is a good place to start with all the black boxes in these cars. Leave it disconnected for about 30 minutes. Use that time to disassemble the dash and check the connectors on the back of the instrument cluster. There'* been a rash of these problems with our members, going all the way back to the 88 models. Yours is the first of the 00-02 I've seen, but considering your troubleshooting so far, these are the next best 2 steps.

Welcome to the forum!
willwren is offline   Reply With Quote
Old 10-01-2002, 03:36 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2002
Location: Wisconsin
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
PaulyB is on a distinguished road
Default Shop Manual?

Ohh yea... if anyone knows where I can get a Shop Manual it would be appreciated also The only place I could find was from GMGoodwrench.com
PaulyB is offline   Reply With Quote
Old 10-01-2002, 08:52 AM   #4
Senior Member
True Car Nut
 
Join Date: May 2002
Location: Edmonton, AB Canada
Posts: 2,621
Thanks: 0
Thanked 0 Times in 0 Posts
DeathRat is on a distinguished road
Default

Well it may be the BCM (Body Control Module). This controls your signal lights & everything else not engine related.
As for the manual try:
http://www.helminc.com/
OR
http://www.kenmcgeeautobooks.com/
Both offer manuals.
DeathRat is offline   Reply With Quote
Old 10-01-2002, 06:10 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2002
Location: Wisconsin
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
PaulyB is on a distinguished road
Default

Sounds good to me... Where is the BCM located, and is there a way to test it at all? Thanks for the suggestion
PaulyB is offline   Reply With Quote
Old 10-01-2002, 09:07 PM   #6
Senior Member
True Car Nut
 
Join Date: May 2002
Location: Edmonton, AB Canada
Posts: 2,621
Thanks: 0
Thanked 0 Times in 0 Posts
DeathRat is on a distinguished road
Default

It'* located under the hood BUT beyound YOUR capabillities of testing it as it will ONLY respond to a TECH II SCAN TOOL. I'm afraid you will have to either take it into the dealer or another licensed garage that has a capable tech that can access this unit.
DeathRat is offline   Reply With Quote
Old 10-02-2002, 11:46 PM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2002
Location: Wisconsin
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
PaulyB is on a distinguished road
Default

Damn...Ok well where exactly under the hood, i just want to see it so I understand what im looking for.

Do you know what this all controls? KInda currious!

Thanks again
PaulyB is offline   Reply With Quote
Old 10-03-2002, 01:37 PM   #8
Senior Member
True Car Nut
 
Join Date: May 2002
Location: Edmonton, AB Canada
Posts: 2,621
Thanks: 0
Thanked 0 Times in 0 Posts
DeathRat is on a distinguished road
Default

The BCM (or Body Control Module) controls EVERYTHING NOT Engine/Trans related! As for the exact location I'll find out!
DeathRat is offline   Reply With Quote
Old 09-26-2009, 01:42 AM   #9
Member
Posts like a V-Tak
 
z302's Avatar
 
Join Date: Sep 2009
Location: ohio
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
z302 is on a distinguished road
Default

I am having the exact same problem on my 2000 ssei did anyone find the cause or were the bcm is located
z302 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
weird cabin electrical probs on a 2000 LeSabre sonoma_zr2 Everything Electrical & Electronic 1 01-05-2007 11:32 PM
Shaved pics and Elec Water pump 95naSTA Your Ride: GM Pictures & Videos 8 08-11-2004 03:50 PM
9-way seat elec functions won't switch to passenger bill buttermore Everything Electrical & Electronic 5 07-12-2004 11:31 PM
1989 sse elec climate control tacordes General GM Chat 1 08-15-2003 02:31 PM
idle probs and starter probs(kinda long) 92ssei 1992-1999 6 04-02-2003 04:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:03 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.