1993 Bonne runs rough - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-21-2004, 08:25 PM   #11
Member
Posts like a V-Tak
 
Join Date: Nov 2002
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Bdd8591 is on a distinguished road
Default

Coolant guys . Bud it'* the intake!!!!!!
Bdd8591 is offline   Reply With Quote
Old 06-21-2004, 09:12 PM   #12
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
John Kirk is on a distinguished road
Default 1993 Bonne runs rough

No check engine or service engine soon light is on.

John
John Kirk is offline   Reply With Quote
Old 06-21-2004, 10:11 PM   #13
Senior Member
True Car Nut
 
Join Date: Dec 2003
Location: Corn Fields, IN
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
John Deere Boy is on a distinguished road
Default Re: 1993 Bonne runs rough

Quote:
Originally Posted by John Kirk
Where is the MAF sensor & the IAT sensor located? Can these be cleaned or must they be replaced?
The MAF sensor is on the throttlebody (which you should clean too!) and the IAT is in the plastic airfilter box.

I"m like the Wendy'* guy about throttlebody cleaning...i go around telling everybody they should do it cause it helps me so much everytime i clean it, which is about once every other year.
John Deere Boy is offline   Reply With Quote
Old 06-22-2004, 12:29 PM   #14
Junior Member
Posts like a V-Tak
 
Join Date: Jun 2003
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
2MCHPSI is on a distinguished road
Default

missing intermittantly?? Sounds ignition related to me.. If it is around the 40-44 mph under load it could be the lock up converter related..

I would check the coil pack and wires first. Do not replace parts until you find something wrong.
2MCHPSI is offline   Reply With Quote
Old 06-22-2004, 01:44 PM   #15
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
John Kirk is on a distinguished road
Default 1993 Bonne runs rough

Is the coil pack what the spark plug wires connect to?
Also, when you guys talk about cleaning the throttle body, do youan with gumout spray?
Thanks,
John
John Kirk is offline   Reply With Quote
Old 06-22-2004, 02:29 PM   #16
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
John Kirk is on a distinguished road
Default 1993 Bonne runs rough

Ok, I did some research on the coil, but how do I check it? How would I know if one of the coils is bad?
Thanks,
John
John Kirk is offline   Reply With Quote
Old 06-22-2004, 02:36 PM   #17
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Don't use gumout on the throttle body unless the can specifically states "intake safe" or "sensor safe". And simply spraying it won't do much good. You need to entirely remove it from the car. There are plenty of posts on that topic here already.

Coilpack troubleshooting is in Techinfo.
willwren is offline   Reply With Quote
Old 06-22-2004, 02:41 PM   #18
Senior Member
True Car Nut
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default

should he try to run some codes?
ssesc93 is offline   Reply With Quote
Old 06-22-2004, 02:52 PM   #19
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

I assume he'* already done that.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buick 3800 barely runs on cold start...then runs fine racer42 General GM Chat 3 03-04-2011 01:13 AM
1990 Bonneville SE, intermittently stalls, runs rough BREWSKI1 1987-1991 11 02-13-2005 12:49 PM
Runs Rough... Poor acceleration... 1994ta 1992-1999 22 02-08-2005 01:52 AM
Check Engine Light, Runs rough 99BonnieinPhilly 1992-1999 2 11-04-2004 02:02 PM
Runs rough at low idle or go slow - no bad codes showing! muddtank 1987-1991 17 08-25-2003 06:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.