Please help!!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-03-2009, 02:56 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: Honesdale pa.
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
tattooartist2005 is on a distinguished road
Unhappy Please help!!!

My 87 bonneville when its moving runs great but in stop and go traffic or stopping at red lights and stop signs it starts running crappy and sputters and hesitates when you try to get going again and sometimes stalls. what can I do to fix this problem???
tattooartist2005 is offline   Reply With Quote
Old 06-03-2009, 07:33 PM   #2
Banned
Posts like a Turbo
 
ricosuave420's Avatar
 
Join Date: Sep 2008
Location: cranford nj
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
ricosuave420 is on a distinguished road
Default

the first thing i would do would possibly be check your plugs and wires and if not that get your fuel filter changed, my 93 ssei would stall on start up and sputter at red lights when i had an old fuel filter and getting it changed fixed everything
ricosuave420 is offline   Reply With Quote
Old 06-03-2009, 07:38 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: Honesdale pa.
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
tattooartist2005 is on a distinguished road
Default

i ran a computer on it and its says lean
tattooartist2005 is offline   Reply With Quote
Old 06-03-2009, 07:55 PM   #4
Banned
Posts like a Turbo
 
ricosuave420's Avatar
 
Join Date: Sep 2008
Location: cranford nj
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
ricosuave420 is on a distinguished road
Default

that means that your gas is to rich, but unfortunately im not to sure how to fix that, but i think it means that your not getting enough air into the engine, not to sure, but try and fin out how to fix rich gasoline
ricosuave420 is offline   Reply With Quote
Old 06-03-2009, 07:57 PM   #5
Banned
Posts like a Turbo
 
ricosuave420's Avatar
 
Join Date: Sep 2008
Location: cranford nj
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
ricosuave420 is on a distinguished road
Default

maby, but check with danathurs first, but you might have to change your O2 sensor
ricosuave420 is offline   Reply With Quote
Old 06-03-2009, 08:47 PM   #6
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

What type of computer did you run? Was there a code number?

Clean the MAF off with a MAF Spray Cleaner and then clear the code.

It also sounds like you might have a fule filter that needs to be replaced as well.

If the trouble returns replace the O2 sensor and also look for vacuum leaks.
Purplehazeir is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ANYBODY please, please help, car alarm driving me NUTS aodessey 1987-1991 17 11-29-2008 02:05 PM
Please, please PLEASE! willwren Lounge 20 03-26-2008 01:16 PM
HELP HELP HELP, EXPERTS PLEASE !! statusplease 1992-1999 8 03-15-2008 06:49 PM
ELECTRICAL PROBLEMS< PLEASE HELP, PLEASE jamesdean26hfx 1992-1999 3 09-20-2004 07:45 PM
The WP is driving me crazy, please....oh...please help me! valerka 1992-1999 2 07-28-2004 11:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.