abs and brake light issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-13-2006, 11:28 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2004
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
kaptnjack is on a distinguished road
Default abs and brake light issue

I read several pages of posts and searches and while there is always great info....it doesent "exactly" address my issue.

90 sse.

Ok...car runs great, new brakes, rotors, pads, shoes etc.

When I hit the brake pedal normally, the red brake light and the yellow abs light come on together (maybe a half second delay between the two, red brake first..then yellow abs) and the peddle seems at first loose for an 1" and then hard. Braking is there and the car is drivable if I am careful but in no way would it stop in an emergency situation.

This situation occurs when the car is moving and in park.....running or not. Each time I hit the brake pedal...both lights come on. Let off the pedal...lights go off.....running or not.

In a driving situation where I slightly apply peddle pressure for a few seconds before actually braking ...and then depress brake slowly...it seems that the peddle feels more accurate and the braking is more normal, the lights dont come on but nowhere near perfect braking before.

When I turn the ignition to the on postion I can hear a click at the MC and about 2 seconds later another click but thats it. If I let it sit say 15 minutes and do the same routine.....I hear the first click...I hear a motor/pump run for about 2 seconds...click...then nothing.

When I hit the brake pedal fast...it feels loose down to about 1-2" and then hits a hard spot...from there its hard but spongy if that makes sense. If I slowly depress the pedal...I dont feel the loose/hard issue but the pedal has the hard/spongy feel all the way

Having read all relative posts about teves, pumps, relays, lines etc and upon inspection.....there are no visible leaks and fluid is at correct level. It is the Teves system as displayed at the REATTA site with the black sphere accumaltor.

Posters have talked about a relay issue and motor/brush refurbishment that may be related. There are several electrical connections at the MC....what do I look for?

Any thoughts will be appreciated.

http://www.justrightdomains.com/car/car.htm
kaptnjack is offline   Reply With Quote
Old 12-13-2006, 11:16 PM   #2
Senior Member
Posts like a Northstar
 
Join Date: Apr 2006
Location: Dimondale, MI
Posts: 549
Thanks: 0
Thanked 0 Times in 0 Posts
F14CRAZY is on a distinguished road
Default

http://reatta.net/brakes/brakes_troubleshooting.html

Click there and take the brake test. Report back with your finds
F14CRAZY is offline   Reply With Quote
Old 12-14-2006, 11:01 PM   #3
Senior Member
Posts like a Camaro
 
padgett's Avatar
 
Join Date: Jul 2003
Location: Orlando, Florida
Posts: 872
Thanks: 0
Thanked 0 Times in 0 Posts
padgett is on a distinguished road
Default

If both lights go out shortly after starting but come on during braking then it is probably a very bad accumulator. Yellow (ABS) light will come on anytime there is a problem in the boost (red light) circuit. About $120 and spins on/off like an oil filter.

Continued use that way will stress and eventually burn out the pump motor. Then you are talking real money.
padgett is offline   Reply With Quote
Old 12-15-2006, 10:09 AM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2004
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
kaptnjack is on a distinguished road
Default

thanks for the advise from everyone...

Th thing that doesnt seem to jive when considering an accumulator failyre is that many posts suggest that the pump may run continuosly when the accumulator fails....mine runs for just maybe 2-3 seconds and then shuts off.

is this still a symptom of the accumulator failing/failed?
kaptnjack is offline   Reply With Quote
Old 12-15-2006, 11:39 AM   #5
Senior Member
Posts like a Camaro
 
padgett's Avatar
 
Join Date: Jul 2003
Location: Orlando, Florida
Posts: 872
Thanks: 0
Thanked 0 Times in 0 Posts
padgett is on a distinguished road
Default

Runs for long time when start in morning aftter sitting all night. May not run for long when engine running but will run every time the brake is used (normally can go for 3-5 stops before runs).
padgett is offline   Reply With Quote
Old 12-15-2006, 11:59 AM   #6
Senior Member
Posts like a Northstar
 
Join Date: Apr 2006
Location: Dimondale, MI
Posts: 549
Thanks: 0
Thanked 0 Times in 0 Posts
F14CRAZY is on a distinguished road
Default

If you can only get one pump (or less, like barely touching the pedal) without the brake pump turning on, it'* a bad accumulator
F14CRAZY is offline   Reply With Quote
Old 12-19-2006, 11:32 AM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Nov 2004
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
kaptnjack is on a distinguished road
Default

update....

ok...when driving or sitting still, I touch the brake normally and the red brake light comes on and a split second later the yellow abs light comes on. Then while still on the brake...both go off.

If I apply the brake ever so slightly...they dont come on at all.

typically under normal braking...the pedal is a little hard but mushy and braking is less than optimal.

I can hear rhe pump start and run for just a second or two when I touch the brake then shuts off.

Any ideas where to start?

Based on my reading hear...a good place may be to remove and clean the switch. after that...its a toss up between replacing the accumulator and/or rebuild/replace the pump.

any other advice on troubleshooting?
kaptnjack is offline   Reply With Quote
Old 12-19-2006, 11:40 PM   #8
Senior Member
True Car Nut
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

it'* the accumlator, because it goes off while on the pedal... it has no built up pressure, so it needs the pump, pump kicks on, pressure goes up, light off. I say just go to the jyard and grab one off an SSE. I have a weak one, but nowhere near as bad as your'*. I'm sure you can at least find one better than your'*... and you may get lucky and have the jyard not know what it is and give it to ya cheap.... maybe a vacuum reserve canister perhaps? That might be asking for a bit too much though. I'm not 100% sure, but I think removal of the accumulator is as easy as getting a strap wrench and twisting it off.

Overnight it takes about 20-30sec for the brake light to go out after firing up the car in the morning.
opensourceguy is offline   Reply With Quote
Old 12-24-2006, 03:20 AM   #9
Senior Member
Posts like a Northstar
 
Join Date: Apr 2006
Location: Dimondale, MI
Posts: 549
Thanks: 0
Thanked 0 Times in 0 Posts
F14CRAZY is on a distinguished road
Default

GMpartsdirect.com has new accumulators for around $117 shipped.
F14CRAZY is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1998 Catera - Check Engine Light, ABS Light and TC light on lucille2 Cadillac 2 02-10-2011 11:58 AM
ABS light on, cannot read ABS codes?! B4CTROOPER 2000-2005 1 01-04-2010 06:53 PM
Check Gages-BRAKE light, trac off light, and Antilock light all on MissRockstar04 2000-2005 9 07-07-2009 05:12 PM
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
ABS and Brake Light On, found fluid above fill to line. mrftw1975 1987-1991 7 05-26-2006 03:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.