87 Bonneville Running Problems - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1987-1991 Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-09-2006, 04:56 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2006
Location: North Vancouver, BC, Canada
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
aeroplan73 is on a distinguished road
Default 87 Bonneville Running Problems

I recently bought a 87 Bonneville with 200000km. It has run great for 5 months, but now there is a problem. It will start, and idle for a few mins, then the 'Check Engine' light comes on. The car continues to idle, but the RPM'* go up and down on their own, and when placed into gear, the car has no power and stalls. I can feather the gas pedal, and it will go a few blocks, but only around 15mph.

It now sits in my underground parking spot.

I bought a code reader, and 32,34 problem codes are showing. The 'Check Engine' light had been coming on for a couple of months prior at random, but I didn't pay attention as the car ran excellent.

Any advice would be great. I am not close to a GM dealership, and if it'* a simple sensor or circuit, I'd like to think I can do it.

Thank you all in advance,

Chris.
aeroplan73 is offline   Reply With Quote
Old 07-09-2006, 07:28 AM   #2
Junior Member
 
Join Date: Mar 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
myfirstbonnie is on a distinguished road
Default

From what I found:

32 EGR valve did not change when the command was given during off-idle operation
34 There was no MAF signal for over 4 seconds while engine was running

It looks like the EGR might be stuck open which will cause a problem with the engine running. Also if there is no MAF signal, the ECM will not be able to control the air/fuel mixture.

Here is a link to a site with the codes.

http://www.troublecodes.net/GM/88-90_38C.shtml
myfirstbonnie is offline   Reply With Quote
Old 07-14-2006, 01:46 AM   #3
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

of the maf is dead that would cause ALOT of running problems and would explain your idle/stalling problem, see if it is connected (its the black box on the top and in front of the throttle body) if it is they remove it and clean it maybe its just dirty.
DarkShadow is offline   Reply With Quote
Old 07-14-2006, 01:48 AM   #4
Junior Member
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Quote:
Originally Posted by DarkShadow
of the maf is dead that would cause ALOT of running problems and would explain your idle/stalling problem, see if it is connected (its the black box on the top and in front of the throttle body) if it is they remove it and clean it maybe its just dirty.
Actually, if he has a 3.8 SFI, the MAF will be inline with the air tubes going to the TB.

You have this engine?
Bonneville92V688 is offline   Reply With Quote
Old 07-14-2006, 02:32 AM   #5
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

Quote:
Originally Posted by Bonneville94V688
Quote:
Originally Posted by DarkShadow
of the maf is dead that would cause ALOT of running problems and would explain your idle/stalling problem, see if it is connected (its the black box on the top and in front of the throttle body) if it is they remove it and clean it maybe its just dirty.
Actually, if he has a 3.8 SFI, the MAF will be inline with the air tubes going to the TB.

You have this engine?
whoopsie forgot all about that *feels dumb now* but yea it will be where he said it is
DarkShadow is offline   Reply With Quote
Old 07-28-2006, 07:28 AM   #6
Junior Member
 
Join Date: Jul 2006
Location: SWEDEN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Deadbringer is on a distinguished road
Default

hi
i have the same problem as aeroplan73

can someone explain how it can be fixed

the repairman took 676 USD just to do a test but he did not understand the what the problem was

please answer what i can do by myself
Deadbringer is offline   Reply With Quote
Old 07-28-2006, 07:55 AM   #7
Senior Member
Posts like a Corvette
 
Join Date: Jun 2005
Location: Berkeley, IL
Posts: 1,596
Thanks: 0
Thanked 0 Times in 0 Posts
DarkShadow is on a distinguished road
Default

Quote:
Originally Posted by Deadbringer
hi
i have the same problem as aeroplan73

can someone explain how it can be fixed

the repairman took 676 USD just to do a test but he did not understand the what the problem was

please answer what i can do by myself
id go back and demand a refund if i were you.

is your service engine soon light on?
DarkShadow is offline   Reply With Quote
Old 07-28-2006, 08:22 AM   #8
Junior Member
 
Join Date: Jul 2006
Location: SWEDEN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Deadbringer is on a distinguished road
Default

have owned the car for 7 years the last 6 years it has been in my garage


yes service engine is light
and it does the same as aeroplan73


sry for my languege
Deadbringer is offline   Reply With Quote
Old 07-28-2006, 08:29 AM   #9
Senior Member
True Car Nut
 
Join Date: Oct 2005
Location: Central Florida
Posts: 7,030
Thanks: 0
Thanked 0 Times in 0 Posts
lash is on a distinguished road
Default

Wow Deadbringer, your mechanic took you, IMO.

Both of you need to check the MAF sensor connection to ensure the contacts are working. If so, start the car and then disconnect the MAF and see if that makes a difference

Be patient and work with us and we should be able to help you two get your cars back on the road. Make sure that you try the things mentioned and be descriptive in your explanations of what is happening. It will help.

Also, let'* make sure we do diagnosis before parts replacement, as much as is possible.
lash is offline   Reply With Quote
Old 07-28-2006, 08:43 AM   #10
Junior Member
 
Join Date: Jul 2006
Location: SWEDEN
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Deadbringer is on a distinguished road
Default

i suck on this where can i find the MAF sensor connection

picture pls


is MAF =MASS AIRFLOW SENSOR if it is can i take out the fuses


http://www.blocket.se/vi/8887969.htm?ca=23_9_s
Deadbringer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Running Problems john92 1992-1999 3 04-27-2009 12:42 AM
running problems with 1996 Grand Am 3100 harofreak00 Lounge 3 10-30-2007 10:00 PM
'98 SE running problems tentmaker1 1992-1999 5 08-27-2007 06:12 PM
Problems, Problems, Problems... swartlkk 2000-2005 2 11-04-2005 08:57 PM
problems, problems, problems big_boss2010 1992-1999 15 04-25-2004 09:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.