Problem with 89 Fuel Injected Suburban (5.7L) - No start - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat
GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat

Go Back   GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat > General Offtopic Chat > Lounge

Lounge For casual talk about things unrelated to General Motors. In other words, off-topic stuff. And anything else that does not fit Section Description.

LinkBack Thread Tools Search this Thread
Old 03-20-2007, 12:05 AM   #11
Senior Member
True Car Nut
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road

My first thought would also be the ignition module. The second would be the coil.
Archon is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
09 Suburban Climate Control Problem Brian0445 GMC/Chevrolet Truck/SUV 3 06-04-2015 08:10 AM
'07 Suburban Remote Start quit Working PtownBubba GMC/Chevrolet Truck/SUV 15 11-01-2012 06:45 AM
GM to release a 300hp Direct Injected 3.6 V6 petraman Lounge 5 02-02-2007 08:57 PM
Can you flood a fuel injected car? Str8pimpin 1992-1999 19 11-30-2004 07:44 PM
1984 camaro engine swap carb to fuel injected! killer_cr80r Lounge 7 10-31-2004 08:44 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:41 AM.