STALLING IN REVERSE only when engine warm - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-02-2012, 11:47 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
aminoacid is on a distinguished road
Default STALLING IN REVERSE only when engine warm

Hi. I'll make it short. 3.4 V6. 2004 grand am

Car stalls in REVERSE only and ONLY when its fully warmed, worse under load (AC on). Will jerk, sputter, rpm gauge goes crazy, chugs, backfires and dies.

Driving fwd is fine. just threw P0304 cylinder 4 misfire which might be from lifters? (i think this is unrelated to the reverse stalling) Previous owner was obviously dishonest and I got suckered. Buyers remorse.


new plugs, wires, coils, EGR valve, just changed oil and added marvel mystery oil maybe to help the lifters.

I need some guidance please.
aminoacid is offline   Reply With Quote
Old 07-02-2012, 01:43 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i think your problems are related, sounds like a vacuum leak, maybe from intake manifold gaskets. as your engines rpm declines the alt output goes way down and causes that other junk. i would see about the misfire then if it is separate go from there. you have any white stuff in the oil, or rad cap? sometimes you can check for vacuum leak by spraying around stuff (cyl 4 area especially in your case) with carb or maf cleaner, listen for engine to change pitch. that engine has known issues with the gaskets and i think felpro has a updated set for the job.
jwfirebird is offline   Reply With Quote
Old 07-02-2012, 03:51 PM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
aminoacid is on a distinguished road
Default

Oil not milky and no signs if external antifreeze leaking. The missfire seems intermittant one second its misfiring and less power and another minute its running fine. Driving car today and its not stalling in reverse today. I cleaned the battery terminals with baking soda and the ground from battery to body. Not sure if the stalling was related to that. I found the evap hose that goes to the purge solenoid broke and I glued that back in temp fix.
aminoacid is offline   Reply With Quote
Old 07-02-2012, 04:40 PM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

that would be a vacuum leak, i dont know about the 3400 but the 3800 the hose from the tb to the purge valve goes to the fuel pressure regulator so a leak would cause the fuel pressure to be screwy too. misfires can be fuel related.
jwfirebird is offline   Reply With Quote
Old 07-02-2012, 05:54 PM   #5
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
aminoacid is on a distinguished road
Default

this is what was broke, notice the red silicone on it. I think its the evap purge solenoid.
Attached Thumbnails
STALLING IN REVERSE only when engine warm-engine.jpg  
aminoacid is offline   Reply With Quote
Old 07-02-2012, 07:13 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

Ya that side has to go toward the tb if it leaks that'* a vacuum leak
jwfirebird is offline   Reply With Quote
Old 07-02-2012, 07:44 PM   #7
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
aminoacid is on a distinguished road
Default

on the 3400, pcv valve goes to this purge solenoid and from there the evap hose goes to I;m assuming canister. It also has a plug. doesn't seem to go to the throttle body at all.
aminoacid is offline   Reply With Quote
Old 07-03-2012, 07:11 AM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

its got to. it might share a hose with the pcv but its job is to take the vapors from the canister and control there release into the engine. its possible that it could go to the manifold somewhere, same difference really
jwfirebird is offline   Reply With Quote
Old 07-15-2012, 11:35 AM   #9
Junior Member
Thread Starter
 
Join Date: Jul 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
aminoacid is on a distinguished road
Default

UPDATE: after fixing that evap purge solenoid and zip tieing the tranny wires properly and cleaning the battery terminals, it stopped the stalling. Not sure what fixed it.

Thanks also for your help guys. Greatly appreciated. Keep up the good work and may God bless you all.
aminoacid is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
running rough / stalling when warm name GMC/Chevrolet Truck/SUV 5 09-08-2014 09:33 PM
Help! Weird Sputtering on 2000; only when warm. baldeville 2000-2005 40 11-24-2010 12:50 PM
97 Bonneville SE stalls when warm, only at idle ninjaman 1992-1999 9 10-01-2009 12:39 AM
Update - engine surges at idle when engine is warm billha 1992-1999 8 06-28-2005 12:55 PM
I have lost my over drive but only when warm FIXED!!!!!!!! doo700 1992-1999 69 08-06-2004 01:36 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.