Runs like CRAP- will not stay in overdrive - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Pontiac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-12-2011, 01:59 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
BonnyDriver is on a distinguished road
Default Runs like CRAP- will not stay in overdrive

I have a '93 Bonneville SE and I replaced the plugs and wires and the car still runs rough and the car seems to BOG down between 45MPH and 50MPH. It'* like it won't stay in 4th gear! My gas mileage is also CRAPPY. I thought it may be a clogged Catalytic Converter so I banged on the Cat when it was cold- NO rattle! I checked for trouble codes and there are NO trouble codes- only Code 12 (System Pass)! I also checked the transmission fluid. It'* O.K. Doesn't smell burned and is still RED. Any ideas?
BonnyDriver is offline   Reply With Quote
Old 02-12-2011, 10:00 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

How old is the O2 sensor?
Danthurs is offline   Reply With Quote
Old 02-13-2011, 03:43 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
BonnyDriver is on a distinguished road
Default

Ordered an O2 sensor online. Will follow up in a few days. Thanks!
BonnyDriver is offline   Reply With Quote
Old 02-17-2011, 12:41 AM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
BonnyDriver is on a distinguished road
Default

O2 sensor was fine. I decided that I would replace the Cat after all! The way the car runs rough and the poor gas mileage all POINT to a clogged Cat! I bought a Universal but I don't see a notch or an arrow etched into the metal to show me which side is Inlet/Outlet. Both sides are 2.5"
BonnyDriver is offline   Reply With Quote
Old 02-17-2011, 02:04 AM   #5
Senior Member
Posts like a Corvette
 
Nighthwk12's Avatar
 
Join Date: Feb 2009
Location: Jersey Shore
Posts: 1,511
Thanks: 0
Thanked 0 Times in 0 Posts
Nighthwk12 is on a distinguished road
Default

I would guess there is no backwards. I would check for a cracked exhaust manifold. Try cleaning your MAF.
Nighthwk12 is offline   Reply With Quote
Old 02-17-2011, 11:01 AM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
BonnyDriver is on a distinguished road
Default

Thanks Nighthwk12! I will make sure to check those things. I called the manufacturer of my universal cat. and he said that it does NOT matter which way you put the cat on. You guessed RIGHT on! Thanks again!
BonnyDriver is offline   Reply With Quote
Old 02-17-2011, 11:25 PM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Oct 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
BonnyDriver is on a distinguished road
Default

Thanks DANTHURS and NIGHTHWK12 for your help!
BonnyDriver is offline   Reply With Quote
Old 02-17-2011, 11:51 PM   #8
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

No problem at all, any time.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buick 3800 barely runs on cold start...then runs fine racer42 General GM Chat 3 03-04-2011 01:13 AM
Changed MAF and Bonnie still runs like crap? trixster68 1992-1999 0 07-31-2009 07:40 PM
Went to store-had overdrive, coming back-NO OVERDRIVE Hafrod Buick 13 06-01-2006 10:44 PM
1992 SE Returns to life but runs like crap ucrm4c 1992-1999 3 07-13-2005 01:36 PM
overdrive or not to overdrive duffer26 1992-1999 10 03-13-2004 12:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.