Successful 3.4" MPS install? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Performance, Brainstorming & Tuning Talk about modifications, or anything else associated with performance enhancements. Have a new idea for performance/reliability? Post it here. No idea is stupid! (please use Detailing and Appearance for cosmetic ideas)

Reply
 
 
 
Thread Tools Search this Thread
Old 07-07-2007, 06:44 PM   #1
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jul 2004
Location: Winnipeg, Manitoba, Canada
Posts: 1,445
Thanks: 0
Thanked 0 Times in 0 Posts
captainmiller is on a distinguished road
Default Successful 3.4" MPS install?

First off, a big thanks out to BillBoost for lending me his pulley puller via mail...

I just want to make sure everything sounds ok since I know there are risks involved when lowering pulley sizes.

I just got a 3.4" MPS installed, with a larger idler and Autolite 104'* @ 0.55" gap. My test day included 70% humidity @ 31 C (which is about 90 F). On my first couple of WOT runs I pulled less then 1 degree of KR throughout the RPM range @ 9.7 lbs of boost. As heat soak set in and the car was in stop and go traffic, I would get a spike of about 4 degrees and it would settle under 2 degrees. The power improvement is huge.

I noticed on a first few WOT runs I would get a quick pop in the exhaust, almost like a misfire. It only happened on 2 or 3 runs and then it stopped completely. Should this be something to look into?

So, I take it this was a success? I also installed a manual rad-fan turn on which is excellent in stop & go traffic. I think next up is getting a PCM from DHP.
captainmiller is offline   Reply With Quote
Old 07-07-2007, 09:58 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

give the PCM about 100 miles to learn....then do some runs
1993 SLE is offline   Reply With Quote
Old 07-11-2007, 08:49 PM   #3
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Jul 2004
Location: Winnipeg, Manitoba, Canada
Posts: 1,445
Thanks: 0
Thanked 0 Times in 0 Posts
captainmiller is on a distinguished road
Default

Well after havng the 3.4 for a little while, a have a few observations.

Heatsoak is killing me. My CAI isn't working well in those blistery hot days. Would a FWI be an idea for this problem?

I have KR at weird times. My car does this thing, where if I normally accelerate to a given speed, and I am in 3rd gear, and then I romp it, it will only go down to 2nd gear (even thought my vehicle speed is still in 1st gear territory), and I will get massive amounts of KR in mid-range RPMS'* (7 degs).

Now say I get up to a given speed (like 40km/h), let the car coast, and then mash it, it down shifts to 1st, I get very little KR all through the power band and it takes off like a rocket.

What is with this mid-range KR?
captainmiller is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Puller for Intense MPS Install silverws6ta General GM Chat 1 01-22-2008 10:23 AM
Puller for Intense MPS Install (Cross Post) silverws6ta Forced Induction 1 01-22-2008 12:11 AM
Puller for Intense MPS Install (Cross Post) silverws6ta 2000-2005 1 01-22-2008 12:08 AM
Magazines That Weren't Successful MOS95B Lounge 0 04-20-2006 02:23 PM
Successful Tranny swap!!!! lkrieger3 1992-1999 5 02-26-2004 02:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.