S10 is dead again.... - Page 3 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Lounge For casual talk about things unrelated to General Motors. In other words, off-topic stuff. And anything else that does not fit Section Description.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-14-2007, 01:16 AM   #21
Senior Member
Posts like a Corvette
 
Join Date: Mar 2005
Location: Frederick, Maryland
Posts: 1,441
Thanks: 0
Thanked 0 Times in 0 Posts
VigCS is on a distinguished road
Default

Quote:
Originally Posted by Bonneville94V688
LIM gaskets installed, etc. O-rings will be at Napa in the morning, ONLY place that carried the kit. Should be up and running tomorrow, and as promised if it is running good, a burnout vid!
Take care of the license problem first.
VigCS is offline   Reply With Quote
Old 04-14-2007, 01:25 PM   #22
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Going to pick the o-ring kit up at 2 or 3, hope everything goes good. I really plan to have it running today.
Bonneville92V688 is offline   Reply With Quote
Old 04-14-2007, 07:29 PM   #23
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Well its running! But badly. :(

The SES is on, and it is running WAYYYY too rich. The exhaust smoke indicates that. So I pulled the airhat off and looked down in through the TB, excessive gas fumes. I am not sure what it is now, so I guess I will have to scan for the code.
Bonneville92V688 is offline   Reply With Quote
Old 04-14-2007, 07:33 PM   #24
PopaDopaDo
True Car Nut
 
popatim's Avatar
 
Join Date: Jan 2005
Location: NY
Posts: 4,957
Thanks: 0
Thanked 0 Times in 0 Posts
popatim is on a distinguished road
Default

Check your engine vacuum, no vacuum to the FPR will set it to max pressure output.
popatim is offline   Reply With Quote
Old 04-14-2007, 07:34 PM   #25
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

There isn't a vacuum hose on the FPR, since it is in the manifold, it picks its vacuum up on the inside of the manifold.
Bonneville92V688 is offline   Reply With Quote
Old 04-14-2007, 07:39 PM   #26
PopaDopaDo
True Car Nut
 
popatim's Avatar
 
Join Date: Jan 2005
Location: NY
Posts: 4,957
Thanks: 0
Thanked 0 Times in 0 Posts
popatim is on a distinguished road
Default

Well then you'll know its a manifold leak rather than a broken hose.
Did you clean the injectors and replace o-rings while you were in there?
popatim is offline   Reply With Quote
Old 04-14-2007, 07:41 PM   #27
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

Everything was replaced. THe main reason I did the work is because the FPR failed.
Bonneville92V688 is offline   Reply With Quote
Old 04-14-2007, 07:59 PM   #28
PopaDopaDo
True Car Nut
 
popatim's Avatar
 
Join Date: Jan 2005
Location: NY
Posts: 4,957
Thanks: 0
Thanked 0 Times in 0 Posts
popatim is on a distinguished road
Default

Does pulling the CTS fix it? or maybe you need to reconnect it?
By any chance did you check for a leaking injector when you had them out?
popatim is offline   Reply With Quote
Old 04-14-2007, 08:57 PM   #29
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Bonneville92V688 is on a distinguished road
Default

ITS FIXED! I WOT'ed it a couple times and let it idle more. CEL went off! :P
Bonneville92V688 is offline   Reply With Quote
Old 04-14-2007, 09:00 PM   #30
PopaDopaDo
True Car Nut
 
popatim's Avatar
 
Join Date: Jan 2005
Location: NY
Posts: 4,957
Thanks: 0
Thanked 0 Times in 0 Posts
popatim is on a distinguished road
Default

AWESOME!
popatim is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake pedal low again and again and again NMP1 GMC/Chevrolet Truck/SUV 2 07-17-2015 11:56 AM
Looks like I'm pulling the engine again. CONFIRMED, engine dead Danthurs General GM Chat 48 04-13-2011 05:33 PM
Dead laptop, dead iPod, dead life rant wjcollier07 Lounge 24 02-20-2007 07:47 PM
1990 Dead again! Update, seems fixed! crzydmnd72 1987-1991 22 08-16-2006 08:16 PM
Sub Dead or Amp Dead? 79ford Audio (and aftermarket electronics) 24 02-22-2004 01:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.