JUST DIE BABY!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Lounge For casual talk about things unrelated to General Motors. In other words, off-topic stuff. And anything else that does not fit Section Description.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-20-2007, 12:54 AM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2007
Location: Nebraska
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
kcoop99 is on a distinguished road
Default JUST DIE BABY!!

I am asking this question for my dad. He has a 91 pontiac GRAND PRIX I know this is a bonneville forum but the problem may be able to be resolved as a general problem. I own a 2000 SSEI and I have great luck with knowledgable people on here so I am going to ask the question here.....anyway....Like I said, it is a 1991 Grand Prix LE with a 3.1. He has quite a few miles on it and just recently it would just die going down the highway! No sputter, no precursor, just DIE. It would start back up fine and then die again. Does this sound like an electrical issue? Maybe an alternator?? Coil pack?? Ignition module?? We are stumped. Thanks!!!
kcoop99 is offline   Reply With Quote
Old 02-20-2007, 01:10 AM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2006
Location: Bloomington, MN
Posts: 3,693
Thanks: 0
Thanked 0 Times in 0 Posts
GoldenBullet is on a distinguished road
Default

since this is not a 3800 motor it will most likely be moved to the lounge

it could be something to do with maybe the fuel pump overheating or dieing and not working but getting better later, but electrical is my first guess
GoldenBullet is offline   Reply With Quote
Old 02-20-2007, 02:02 AM   #3
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Twin Falls, Idaho
Posts: 7,545
Thanks: 0
Thanked 1 Time in 1 Post
Hans is on a distinguished road
Default

check the connection to the ICM, check the battery cables for corrosion. check other grounds related to the ignition system and the fuel pump....usually located on a ground bus somewhere in the car..you'd need a wiring diagram to be certain. those are good places to start

any check engine light ever?
Hans is offline   Reply With Quote
Old 02-20-2007, 08:21 AM   #4
Junior Member
 
Join Date: May 2006
Location: BonnevilleHell
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
clm2112 is on a distinguished road
Default Re: JUST DIE BABY!!

Quote:
Originally Posted by kcoop99
No sputter, no precursor, just DIE. It would start back up fine and then die again. Does this sound like an electrical issue? Maybe an alternator?? Coil pack?? Ignition module?? We are stumped. Thanks!!!
Sounds electrical to me. If it does it on a regular basis, I'd start be reseating all the electrical connectors and checking the ground wire to the motor and chassis.

My 90 Bonneville LE did that too, chased it around for a while and it was the ECM. Replaced it with a junkyard one, and it is still running on that 50k miles later. But, you still need to start poking around the wiring to find out why yours is cutting out completely.
clm2112 is offline   Reply With Quote
Old 02-20-2007, 10:45 AM   #5
Junior Member
 
Join Date: Mar 2003
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
vital49 is on a distinguished road
Default

Quote:
1987 to 1991
Parley with regards to your 1987 to 1991 Bonneville, Olds 88 or Buick Le Sabre Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.
This is going to the Lounge...
vital49 is offline   Reply With Quote
Old 02-20-2007, 05:48 PM   #6
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

With the 3.1 this can be a few different things...

It could be a bad crank sensor, Bad ICM or Bad ECM.. Possibly even electrical like stated..

Hard to say without being able to look at it..

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 02-20-2007, 08:07 PM   #7
Senior Member
Posts like a Supercharger
 
Join Date: Apr 2005
Location: Naperville, IL
Posts: 176
Thanks: 0
Thanked 0 Times in 0 Posts
RareGMFan is on a distinguished road
Default

I'd start by pulling off the ICM and coils (yes, I know they're a pain to get to on the 3.1), and taking them to a parts store that tests them for free. We'll go from there if those check out ok, but I'm willing to bet one of those is your problem.
RareGMFan is offline   Reply With Quote
Old 02-20-2007, 08:22 PM   #8
Senior Member
Posts like a Northstar
 
Join Date: Jul 2005
Location: Detroit, MI
Posts: 649
Thanks: 0
Thanked 0 Times in 0 Posts
Jason1351 is on a distinguished road
Default

I had the same problem with my 93 3.1 GP. Changed out the ECM with a junkyard piece and it'* still going 90,000 later. Also, if you have it scanned, it'll probably come up as the TPS or ign. module. Mine did that, and after replacing those, thats when we figured it out to be the ECM. Just make sure you switch out the PROM.
Jason1351 is offline   Reply With Quote
Old 02-20-2007, 08:45 PM   #9
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2007
Location: Nebraska
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
kcoop99 is on a distinguished road
Default

PROM?? The ECM, that is the computer, right? He said that the check engine light has not come on. He is going to check the electrical connections but you can probably pick up an ECM from the junkyard for pretty cheap (?)
kcoop99 is offline   Reply With Quote
Old 02-20-2007, 09:16 PM   #10
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jan 2007
Location: Nebraska
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
kcoop99 is on a distinguished road
Default

If the module goes out will you still get spark. It will start but then die but will not stay running. Could this be a fuel filter. He ran out of gas on it on Friday and since when he ran it out of gas it has been worse..................
kcoop99 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Michael Jackson didn't die, he just moved to Brazil and became a taxi driver. niceguy Lounge 2 02-01-2011 11:56 AM
To die or not to die???? 57lxi 1992-1999 1 08-25-2010 10:27 PM
Didn't someone just have a printer die on them?? MOS95B Lounge 1 11-13-2006 09:06 AM
DIE RUST DIE!!!!!! *update* bandit Detailing & Appearance 17 08-22-2006 01:53 PM
Die Cast car models of the Bonneville JosB General GM Chat 4 03-10-2003 06:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:22 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.