Truck cuts off after hard acceleration - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-06-2016, 10:52 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default Truck cuts off after hard acceleration

Lately my truck cuts off after hard acceleration only. I had changed my alternator not to long cause I was having dimming lights and it was bad I also changed my battery to. Now when it shuts off my battery light comes on and my fuel light. So I don't no if it'* my fuel pump or cam/crank sensor any suggestions
denaliman03 is offline   Reply With Quote
Old 01-06-2016, 10:54 PM   #2
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

And no check light
denaliman03 is offline   Reply With Quote
Old 01-07-2016, 05:30 PM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default




Could theses messages cause my cut off issue. Like if I press the acceleration a like more down I will get Traction control active message and it will cut power to the wheels. With no check light I can't figure what to look for .<br/>Ignition <br/>Spark plug wires / spark plugs<br/>Cam/crankshaft sensor <br/>Throttle position sensor <br/>Fuel pump
Attached Thumbnails
Truck cuts off after hard acceleration-80-20160107_145001_c093f400c46493ba897e9ec09c05705e0272f9bb.jpg  
denaliman03 is offline   Reply With Quote
Old 01-07-2016, 05:59 PM   #4
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Service stability will not shut down the engine. Even if the CEL is not lit, it still might be throwing codes. If you don't have a code reader, take it to Autozone and they will read it for free.
2kg4u is offline   Reply With Quote
Old 01-07-2016, 07:14 PM   #5
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

I called auto zone they said if it'* no check light then the scanner won't read. Now all the sensor I listed they all can cause the engine to stall. I'm at lost I would hate to take it to the dealer and then they don't find nothing. Well what ever is cause me to stall on hard acceleration is affect the way my truck drives. I'm a try to change the throttle position sensor and crankshaft sensor and see what happens. Note my alternator and battery been change a month ago so they can be ruled out next I will try my spark plug wires and spark plugs
denaliman03 is offline   Reply With Quote
Old 01-08-2016, 10:41 AM   #6
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Quote:
Originally Posted by denaliman03 View Post
I called auto zone they said if it'* no check light then the scanner won't read. Now all the sensor I listed they all can cause the engine to stall. I'm at lost I would hate to take it to the dealer and then they don't find nothing. Well what ever is cause me to stall on hard acceleration is affect the way my truck drives. I'm a try to change the throttle position sensor and crankshaft sensor and see what happens. Note my alternator and battery been change a month ago so they can be ruled out next I will try my spark plug wires and spark plugs

Autozone'* response is not correct. I've had several situations where the CEL was not lit but codes where thrown and could be read.
2kg4u is offline   Reply With Quote
Old 01-08-2016, 04:17 PM   #7
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Took it back to autozone nothing showed up. So I don't no with this truck
denaliman03 is offline   Reply With Quote
Old 01-09-2016, 09:27 PM   #8
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

Question for any one my tank is a 32 gallon I have the xl 1500 6.0l. I notice once the low gas light comes on I put in 10 dollars of gas at 2.19 divide into 10 that'* 4.5 gallons my need goes to a quater tank. I no half a tank is 16 gallons so a quater tank should be around 8 gallons I'm not mistaken. So my conclusion is that my fuel pump isn't accurate showing me more gas then what I have. So could that be my problem I'm having?
denaliman03 is offline   Reply With Quote
Old 01-10-2016, 04:07 PM   #9
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,589
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

What I would recommend is that you fill the tank to at least 3/4 or full and then see if under hard acceleration it continues to stall.
Possibly with less fuel, it'* sloshing around a bit, and accuracy may be off?
Fuel pressure tests /regulator/ psi at rail / fuel filter been changed?
What year is your Denali? Can you add that to your signature line, be great if you could.
Pro shop Scanners like Solaris & ultra can better diagnose & find codes.
With service stability there are codes stored, and the proper scanner will show them.
Soft Ride is offline   Reply With Quote
Old 01-10-2016, 10:47 PM   #10
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Nov 2015
Location: Philadelphia pa
Posts: 103
Thanked 1 Time in 1 Post
denaliman03 is on a distinguished road
Default

My truck is a 03 I change my fuel pump 2 years ago I haven't tried 3/4 of gas to see of it would stall I'm guessing if it does then the pump no good
denaliman03 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
BONNEVILLE shuts down after hard acceleration XEN 2000-2005 13 10-19-2012 06:22 PM
Car cuts off while driving after dash lights go out chilump 1992-1999 5 06-02-2005 06:48 PM
2000 S/E A/c cuts off Havisman2000 Everything Electrical & Electronic 4 07-08-2004 08:13 PM
Car cuts off...Turn the wheel and car starts up 95BonnevilleSESC 1992-1999 2 02-20-2004 02:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.