Silverado-Security light solid-dead battery - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-05-2013, 10:33 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
cvette04 is on a distinguished road
Default Silverado-Security light solid-dead battery

I have an 02 Silverado LS 4x4. When I close the door the yellow security light stays solid. When this happens it will drain the battery in two days. Also With the key in the on position, either running or not, the air bag light stays on, the ABS light stays on. The Security light, Battery light, Service 4WD, and Low Fuel lights will cycle on and off the this order. The fuel gauge does not work and the Temp gauge does not work.

The truck runs fine, cranks fine, and all other accessories work. If I plan on letting the truck sit for more than a day I have to disconnect battery.

I have tried disconnecting the battery, did not help.
I closed the door and reached in and turned key to the on position and let sit for 10 minutes, this did not help.

Does anyone have any suggestions?
cvette04 is offline   Reply With Quote
Old 06-06-2013, 05:43 AM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Have you had the vehicle scanned for any codes? And by scanned, I mean really scanned. The cheap $50 pocket scanners normally don't scan for body codes. I'm wondering if your Body Control Module is on the fritz because it also controls your instrument cluster. Or, it might be a bad instrument cluster.
Mike is offline   Reply With Quote
Old 06-06-2013, 08:57 AM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

given the number of problems i would guess the cluster is bad. but you take the battery cable loose put a meter in series with it, and see what it is should be relatively low. if not try disconnecting the cluster and see if it goes down. you could do the same with the bcm. sometimes its a stuck relay that continuously on
jwfirebird is offline   Reply With Quote
Old 06-06-2013, 04:37 PM   #4
Junior Member
Thread Starter
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
cvette04 is on a distinguished road
Default

Have not had vehicle scanned. No good place to take it around my area. I went to AutoZone and they said they did not have the correct cable.

Could it be a grounding issue? If so where is the grounding point for these issues?

Vehicle added to sig.
cvette04 is offline   Reply With Quote
Old 06-06-2013, 05:54 PM   #5
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

grounds do not drain batteries
jwfirebird is offline   Reply With Quote
Old 06-06-2013, 06:00 PM   #6
Junior Member
Thread Starter
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
cvette04 is on a distinguished road
Default

Was a suggestion from Autozone. Their reasoning was a bad ground was causing the security system not to reset therefore causing the light to stay on and security system to stay active and thus drain battery.
cvette04 is offline   Reply With Quote
Old 06-06-2013, 06:33 PM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i would start were i suggested, and take parts store advise with a grain of salt
jwfirebird is offline   Reply With Quote
Old 06-06-2013, 06:39 PM   #8
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
battery dead, now temp light blinking and defrost only smote 1992-1999 18 02-04-2008 11:57 AM
Dead laptop, dead iPod, dead life rant wjcollier07 Lounge 24 02-20-2007 07:47 PM
Sub Dead or Amp Dead? 79ford Audio (and aftermarket electronics) 24 02-22-2004 01:55 PM
Dead Battery bonneville 00 General GM Chat 3 05-22-2003 09:45 PM
Dead battery Mayhem_3 1987-1991 1 03-31-2003 08:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.