2005 suburban P0496 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-31-2016, 01:29 PM   #1
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
05burb is on a distinguished road
Default 2005 suburban P0496

Can someone lead me in the right direction please. I have a 2005 Suburban LT with the 5.3 V8 with 4x4. I have issues with the evap system on the vehicle. I have replaced the gas cap several times, the purge valve solenoid by the tank, the solenoid on top of the intake and I still get the P0496 code kicking out. I can reset the code and it will stay off for about a week then it lights up again. Sometimes I have issues with it taking fuel. Almost like the roll over valve is closed on it. Sometimes it will take fuel just fine, and then while filling it up, it will spit out some excess fuel in the fill tube. Can someone point me to the right direction. thanks.




Patrick
05burb is offline   Reply With Quote
Old 05-31-2016, 04:08 PM   #2
Senior Member

Posts like a Turbo
 
Join Date: Feb 2015
Location: Earth
Posts: 239
Thanked 38 Times in 36 Posts
CathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura about
Default

You've replaced solenoids I would have troubleshot. Your symptoms combined with it spitting out fuel when you fill it make me wonder about the tank-vent path. Perhaps it is plugged?

I'm unfamiliar with your driving habits such as miles per day, number of trips, how warmed-up your car gets, etc. Could you elaborate on what your car sees between resetting the code and then MIL lighting up again about a week later?

Also, I wonder if you reset then drive a time or two then scan again and see if you have a pending code.
CathedralCub is offline   Reply With Quote
Old 05-31-2016, 04:15 PM   #3
Junior Member
Thread Starter
 
Join Date: May 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
05burb is on a distinguished road
Default 05burb

It gets driven perhaps 30 miles a day pending on how much running around needs to get done. My wife is the primary driver and she drives easy, I have a little bit heavy foot so I am more aggressive. The only code that comes up every time is the P0496, nothing else. Every time I would replace a part to see if it was the fix, I always reset the computer, the longest is lasted was a month, then it came back on again.
05burb is offline   Reply With Quote
Old 05-31-2016, 05:31 PM   #4
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Here is some more information about the P0496 and some trouble shooting info..
http://www.obd-codes.com/p0496
Soft Ride is offline   Reply With Quote
Old 05-31-2016, 06:14 PM   #5
Senior Member

Posts like a Turbo
 
Join Date: Feb 2015
Location: Earth
Posts: 239
Thanked 38 Times in 36 Posts
CathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura aboutCathedralCub has a spectacular aura about
Default

Quote:
Originally Posted by 05burb View Post
It gets driven perhaps 30 miles a day pending on how much running around needs to get done. My wife is the primary driver and she drives easy, I have a little bit heavy foot so I am more aggressive. The only code that comes up every time is the P0496, nothing else. Every time I would replace a part to see if it was the fix, I always reset the computer, the longest is lasted was a month, then it came back on again.
Cool, clearer picture. I'm guessing that after a couple of cycles of it seeing the problem it stores a pending code for the issue and waits for the issue to continue long enough to light the light. I'd say check for pending codes at the end of each day when it gets back home. Goal here is to identify more closely if the issue is intermittent or if it returns immediately and waits to tell you about it.
CathedralCub is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
P0496 Code GhostRO Pontiac 6 05-31-2015 01:41 PM
Programming 2005 Suburban Remote Entry Fob nvestysly Chevrolet 22 01-04-2014 04:52 PM
2005 Suburban - Radio/NAV/CD Question nvestysly GMC/Chevrolet Truck/SUV 4 12-28-2013 10:26 AM
2005 Suburban front end feeling like a death wobble GunsOfNavarone GMC/Chevrolet Truck/SUV 1 06-15-2011 11:33 AM
Code P0496 on 2006 lacrosse 3.8L azbuick Buick 12 12-18-2010 05:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.