2000 Safari 6cyl AWD Van - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


GMC/Chevrolet Truck/SUV When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-09-2011, 05:30 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
PtownBubba is on a distinguished road
Default 2000 Safari 6cyl AWD Van

I just got this 2000 Safari van, got a great deal, but there are some hiccups I am working on.
The dash lights do not work, or have been told at times they do,,,, just the instrument cluster lights are out,, the heater-AC, radio lights work and go bright dim with dimmer. Tail lights do not go on and off, they are fine also.

The rear hatch,,, the keyed switched is either rusted solid,,, or it has been replaced, and it takes a different key than the ignition/door key. Dash hatch button works fine.

Where can I find a replacement key-switch ??

It was low on antifreeze,,, what I could see, it looked liked the old classic green antifreeze,, not that orange stuff,,,, what was 'original' ? Not sure but itmay have been drained and replaced with classic green ????

Thanks,,,,
PtownBubba is offline   Reply With Quote
Old 08-09-2011, 05:37 AM   #2
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Aug 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
PtownBubba is on a distinguished road
Default

oh,,, and the spare tire looks like it lowers with the winch setup,,, like I said, just got this, need to find jack and handle, and try to lower spare, it appears like it has not been lowered,,,, for a long time,,, may not come down.
PtownBubba is offline   Reply With Quote
Old 08-09-2011, 12:15 PM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

the dash pod connector sounds like its loose or corroded

try squirting wd40 in the hole and working the key in and out sometimes that frees it up, sometimes its the linkage or mech. in the back

probably had dexcool for that year, if they cheaped out and put green in there its probably not good, I always flush and fill with prestone ext. life, you dont have to worry if its right for the car.
jwfirebird is offline   Reply With Quote
Old 08-12-2011, 08:07 AM   #4
Retired Administrator

True Car Nut
 
GunsOfNavarone's Avatar
 
Join Date: Apr 2009
Location: Williamsport, PA
Posts: 2,856
Thanked 167 Times in 129 Posts
GunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud ofGunsOfNavarone has much to be proud of
Default

You have the 4.3L in your Safari. That engine is well known to have lower intake manifold gasket failure, which initially results in loss of coolant.You may want to do a compression test. Are you lower on coolant or is it losing coolant? Also check the water pump, another high failure item on your 4.3L.
GunsOfNavarone is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Safari van no start Marshal GMC/Chevrolet Truck/SUV 11 06-02-2014 08:52 AM
1995 pontiac grand am se 6cyl yourleaseadvisor General GM Chat 1 01-22-2013 01:06 PM
96 Safari Van heater/def ? PtownBubba GMC/Chevrolet Truck/SUV 9 02-15-2012 03:55 PM
Factory Installed or Aftermarket XM for 2005 Safari van settummanque Audio (and aftermarket electronics) 1 01-20-2011 09:28 PM
My 2000 Olds Bravada AWD swartlkk Your Ride: GM Pictures & Videos 25 05-09-2005 09:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.