Surging and Hesitation - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-11-2003, 11:05 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default Surging and Hesitation

I have one quick question....I have a 91 Grand Prix with a 3.1 and just noticed today as I was pulling up my driveway,it started surge high and low.For a second I thought it might be running out of gas but I had a 1/4 of a tank.It idles fine and when you give it gas while out of gear it still sounds normal,no missing or anything of that nature.Any ideas?Thanks for any info you could pass along. UPDATE....It did it while it was idling for a few seconds and then cleared up,no trouble codes either.
Pontiac735 is offline   Reply With Quote
Old 05-13-2003, 12:22 AM   #2
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

Last time I checked it wouldn't start at all,it will catch for a second and stall.A little stumbling and backfiring when it is trying to start but no luck.I check the pressure valve on the fuel rail and there seem to be adequate pressure I guess,I can also hear the pump come on when I turn the key to the on position.I checked the O2 sensor...no luck...checked the TPS to make sure it wasn't loose..tight.Checked the plug wires located on the front of the engine for fire and there was plenty(I wasn't checking the back ones to much work)It smells like the gas is burning rich when I attempt to start it...unusal fumes.So I guess its off to the garage for me.
Pontiac735 is offline   Reply With Quote
Old 05-13-2003, 01:31 AM   #3
Senior Member
True Car Nut
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

Maybe just maybe your Air filter is clogged check that out, also i had a friend whose car did that and it was the crank shaft sensor, but thats a very unlikley cause, it almost sounds like it is flooded...if its supercharged did u put premium 91 octane fuel in it?
SSEimatt93 is offline   Reply With Quote
Old 05-13-2003, 06:18 AM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

I checked the air filter... it'* fine...I had also replaced the crankshaft sensor on this car before...when that happened the car would not attempt to start at all...just turn over and over.No it'* NA.
Pontiac735 is offline   Reply With Quote
Old 05-13-2003, 07:16 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

I have fire on the front plugs so could the module under the coils still be bad?When I turn the key to the on position I hear the fuel pump....could that still be bad also..I checked the valve on the fuel rail and there was alot of gas squirting out.
Pontiac735 is offline   Reply With Quote
Old 05-13-2003, 08:53 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

I just pulled the 3 front plugs out and they were pretty fouled up...black as coal.I put the plugs into the boots and had the car turned over while I watched for spark.2 of the 3 had weaker spark...orange in color.I have an extra computer from another GP...I'll give that a try,anything I should know when swapping that out?Thanks
Pontiac735 is offline   Reply With Quote
Old 05-13-2003, 09:41 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

Is there a special tool that I need to remove the prom from the ecm...if no tool is there any other way of doing it without damaging it
Pontiac735 is offline   Reply With Quote
Old 05-14-2003, 03:12 PM   #8
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

Thanks for all the tips....I'm gonna switch the ecm'* out tonight,hopefully the chips are the same,the cars were identical,and if that don't work I'll try the coils and the modules.If all this doesn't work I'm having a bonfire
Pontiac735 is offline   Reply With Quote
Old 05-14-2003, 10:59 PM   #9
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

I phoned the local junk yard looking for a module and they said they have the three coils and the module for 60Cdn.He said it was coming of a 99 Buick Century,and all I would have to do is change the mounting plate which is different.
Pontiac735 is offline   Reply With Quote
Old 05-15-2003, 05:26 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2003
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Pontiac735 is on a distinguished road
Default

Finally....I changed the ecm and it went with the help of a boost,I put three new plugs in the front where it is easy to reach,the gap was way out,it is supposed to be .45 but it was .55 and they were fouled up from all the starting attempts.I also didn't change the PROM either.It is stalling a little but I think that is just the sensores reseting themselves because it seems to be getting better.So as I get around to it I'll change the back ones.Should I change the prom...would it be causing the stalling?
Pontiac735 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stumbling, Surging, Hesitation ** FIXED ** statusplease 1992-1999 58 03-21-2008 05:28 PM
HELP (Stumbling and Surging under power) koolaidman2021 1992-1999 11 03-05-2008 05:28 PM
Hesitation on accel dn part throttle surging. 01BonneSC 2000-2005 3 08-23-2007 06:39 PM
Loss of power and strange surging Paul General GM Chat 7 11-12-2005 06:49 PM
surging, hesitation only when cold oldfrt46 1992-1999 6 11-07-2002 04:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.