Speedometer stoped working! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-10-2004, 11:04 AM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2004
Location: Toronto, Canada
Posts: 192
Thanks: 0
Thanked 0 Times in 0 Posts
valerka is on a distinguished road
Default Speedometer stoped working!

Hi again, today I will be picking up my new 92 SSEi and i am very excited about it. But on my old 91 SE the speedometer stoped working all of a sudden. The tachometer works just fine but the arrow just lies down and does not prodecu any movemnet what so ever. A couple more thing, the cruise control work just fine but the milage does not get registered. Anyone has any clue what might be the problem?
Thanks in advance!
valerka is offline   Reply With Quote
Old 03-10-2004, 11:12 AM   #2
Senior Member
True Car Nut
 
Join Date: Jun 2003
Location: Purgatory
Posts: 6,313
Thanks: 0
Thanked 0 Times in 0 Posts
PontiacDad is on a distinguished road
Default

The speed signal comes from the pcm, I suspect a loose connection from the pcm to speedo. The fact the cruise works indicates the speed sensor to pcm is ok.
PontiacDad is offline   Reply With Quote
Old 03-10-2004, 11:17 AM   #3
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

yeap PCM could be the problem or the back of the cluster
Kennginn is offline   Reply With Quote
Old 03-10-2004, 12:53 PM   #4
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

Your car isn't happy with the new purchase
BonneMeMN is offline   Reply With Quote
Old 03-10-2004, 12:55 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Instrument cluster removal procedure is in Techinfo.
willwren is offline   Reply With Quote
Old 03-10-2004, 05:19 PM   #6
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Jan 2004
Location: Toronto, Canada
Posts: 192
Thanks: 0
Thanked 0 Times in 0 Posts
valerka is on a distinguished road
Default

Where is PCM located and how does it look like?
valerka is offline   Reply With Quote
Old 03-12-2004, 05:43 PM   #7
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by jr's3800
I agree with Pontiac Dad..... I say this because the cruise does have to have a Vehicle speed signal for the cruise to work... But that deosn't mean the ECM isn't bad... But I get the feeling that the Cluster has taken a crash...
I would have expected a Service Engine light if the problem was anywhere other than in the cluster. Given their history of random components in the cluster failing when the connector pins get oxidized, I'd say this is just another case of that.

Take the cluster out, check the connections and stick it back together again, per the instructions in TechInfo. It'll give you an opportunity to do a little cleaning while it'* apart, and I suspect the big fat multi-pin connector plug in the back may be the culprit here anyway.
acg_ssei is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Power windows stoped working sseisseissei 2000-2005 24 02-17-2010 02:52 PM
Oh great now my dryer stoped working :( 99SilverSE Lounge 4 10-28-2007 11:07 PM
gas gauge and speedometer not working 94 bonne bonnevilledude 1992-1999 2 09-01-2006 08:20 AM
94 bonne fuel gauge /speedometer not working bonnevilledude 2000-2005 1 08-31-2006 08:13 PM
Speedometer not working on 1991 Bonneville LE jdbickelsr 1987-1991 13 01-26-2006 08:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.