So today was my day..... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-05-2007, 06:31 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default So today was my day.....

....cruising home from work at 55 mph, cruise set, I give it a little gas and BOOM!!!!! BLUE smoke, like a mushroom cloud behind me. WTF!!!! I have no clue why. I idled the last 5 miles home, popped the hood and nothing but oil everywhere ..... coming from the Caspers Electronics oil filler cap/breather. Pulled the plugs and #3 is a little bit ackward to say the least.
So, now I have to put a bid in tomorrow on the 98 Regal GS (95k miles) at the auction. Hopefully I can get it for under $500.... that'* the budget until I get paid again.... luckily I'm on Easter break until Wednesday. So I'm not in too big of a time crunch, as long as I have a motor by Monday afternoon.
I am just stupified by this.... I had just scanned the car the other day and saw 0-2* (2* on shifts) KR on two 0-80 runs at full throttle. Didn't check anything else as the guy who owned the Snap-On was in a hurry.
I don't know what to say.... I am stunned..... 55 mph cruising for almost ten miles, 10% throttle and BAM..... Had gotten on it once for a 0-30 when I left work 20 miles earlier. Oh well, 42k on a L67 is a long life isn't it?
I hadn't run the 3.3" since 2 weeks after I put the engine in and even then I only got on it 2-3 times, but never full throttle that I recall. I don't know what the hell happened... at least why -I had actually been taking it easy the past 1000 miles just trying to get decent mileage, with only a couple full throttle runs (less than 10, but about 5 since I got the 3" DP last Friday).
OLBlueEyesBonne is offline   Reply With Quote
Old 04-05-2007, 06:50 PM   #2
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

jeeze.. you just cant hold on to anything!

did you pull the valve covers? maybe you dropped a valve like i did

what color is the regal? good trans?
harofreak00 is offline   Reply With Quote
Old 04-05-2007, 06:54 PM   #3
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Quote:
Originally Posted by harofreak00
jeeze.. you just cant hold on to anything!

did you pull the valve covers? maybe you dropped a valve like i did

what color is the regal? good trans?
Drop a valve at 2200 rpm?

Hit right front.... just what your buddy needs. I don't know on the trans.... have to check the fluid.
OLBlueEyesBonne is offline   Reply With Quote
Old 04-05-2007, 07:08 PM   #4
Senior Member
Posts like a Northstar
 
Join Date: Apr 2006
Location: Robertsdale Alabama
Posts: 500
Thanks: 0
Thanked 0 Times in 0 Posts
hugger10 is on a distinguished road
Default

I get the oil everywhere and #3 cylinder, but what happened?
hugger10 is offline   Reply With Quote
Old 04-05-2007, 07:08 PM   #5
Senior Member
Posts like a Supercharger
 
Join Date: Aug 2006
Location: Minnesnowda....
Posts: 198
Thanks: 0
Thanked 0 Times in 0 Posts
'96BonnevilleL67 is on a distinguished road
Default

That'* too bad Marty. Just have NO luck with that car......
'96BonnevilleL67 is offline   Reply With Quote
Old 04-05-2007, 07:17 PM   #6
Junior Member
 
Join Date: Mar 2004
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
harofreak00 is on a distinguished road
Default

when my valve spring broke in my 00 it was running not so good and then BOOM.. i was going 70mph at 2500rpm when it locked up cuz of the dropped valve
harofreak00 is offline   Reply With Quote
Old 04-05-2007, 07:21 PM   #7
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Quote:
Originally Posted by harofreak00
when my valve spring broke in my 00 it was running not so good and then BOOM.. i was going 70mph at 2500rpm when it locked up cuz of the dropped valve
Yeah, but you were running a cam in there with stock springs IIRC. I guess it'* worth checking....... but I'm just gonna swap a stock motor in and call it a day with this car.
OLBlueEyesBonne is offline   Reply With Quote
Old 04-05-2007, 07:39 PM   #8
Senior Member
Posts like a Northstar
 
Join Date: Apr 2006
Location: Robertsdale Alabama
Posts: 500
Thanks: 0
Thanked 0 Times in 0 Posts
hugger10 is on a distinguished road
Default

Oh is that why your doing so much to your car haro? I somehow figured you had just decided you were going to tear down and build up stronger because of the mileage. Anyways good luck on finding a donor motor.
hugger10 is offline   Reply With Quote
Old 04-05-2007, 07:40 PM   #9
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Quote:
Originally Posted by hugger10
Oh is that why your doing so much to your car haro? I somehow figured you had just decided you were going to tear down and build up stronger because of the mileage.
Andrew actually swapped the motor a while before he started tearing it down again.
OLBlueEyesBonne is offline   Reply With Quote
Old 04-05-2007, 08:58 PM   #10
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Marty...what year was the motor?
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fathers Day gift to myself - And a Happy Fathers Day to all. Paul Your Ride: GM Pictures & Videos 4 06-18-2007 08:14 AM
One day....ONE FREAKING DAY! John Deere Boy Your Ride: GM Pictures & Videos 34 02-23-2006 11:54 AM
ANOTHER day at the wrecker. 2nd DAY! MORE PICS! willwren General GM Chat 33 03-10-2004 03:55 AM
Veterans Day / Remembrance Day MOS95B Lounge 34 11-12-2003 04:52 PM
What a wonderful 80F degree day, how is everyone else's day? 99BonnevilleSE General GM Chat 16 11-25-2002 04:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.