issues.. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-25-2012, 12:08 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2012
Location: Dallas, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Darkman19 is on a distinguished road
Default issues..

im new to the group but i need some advice on whats makin my 99' olds alero burn sooo much gas,, ive replaced these items within the past 6 months in no particlular order to try to fix the problem..
fuel pump, fuel filter, head gasket, thermostat, water pump, serpentine belt, catalytic converter, o2 sensor in front of catalytic converter, .. ive had 2 diagnostics and nothing shows up...yet im still burnin a ton of gas and i only live 10 minutes from work so theres no heavy driving goin on..i need some advice badly on how to fix this...
Darkman19 is offline   Reply With Quote
Old 06-25-2012, 12:18 PM   #2
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,636
Thanked 990 Times in 769 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

I didn't see sparkplugs or wires in the list??? And what temp thermostat did you use?
Mike is offline   Reply With Quote
Old 06-25-2012, 12:26 PM   #3
Junior Member
Thread Starter
 
Join Date: Jun 2012
Location: Dallas, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Darkman19 is on a distinguished road
Default

i did change the spark plugs and wires about 6 months ago hopefully thats not the problem..i dont remember the brand of the thermostat i used but i can find out..also my vehicle tends to run higher than usual..but i was told thats the way GM vehicles are.. i dont know think thats true
Darkman19 is offline   Reply With Quote
Old 06-25-2012, 12:58 PM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

which engine? air filter? someone check the fuel pressure? what exactly do you mean by diagnostic?
jwfirebird is offline   Reply With Quote
Old 06-25-2012, 01:04 PM   #5
Junior Member
Thread Starter
 
Join Date: Jun 2012
Location: Dallas, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Darkman19 is on a distinguished road
Default

by diagnostic i mean i had firestone put it on the machine to see what was wrong since my check engine light keeps comin on even after im constantly replacing parts..
Darkman19 is offline   Reply With Quote
Old 06-25-2012, 01:18 PM   #6
Senior Member
Posts like a 4 Banger
 
Blackarrow98GP's Avatar
 
Join Date: Apr 2012
Posts: 128
Thanks: 0
Thanked 1 Time in 1 Post
Blackarrow98GP is on a distinguished road
Default

What code(*) do you have? If there'* an Autozone nearby you can get them checked for free.
Blackarrow98GP is offline   Reply With Quote
Old 06-25-2012, 01:24 PM   #7
Junior Member
Thread Starter
 
Join Date: Jun 2012
Location: Dallas, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Darkman19 is on a distinguished road
Default

blackarrow i tried the autozone thing and of course they give a list of things that could b wrong never pinpointing the exact problem..
Darkman19 is offline   Reply With Quote
Old 06-25-2012, 01:30 PM   #8
Senior Member
Posts like a 4 Banger
 
Blackarrow98GP's Avatar
 
Join Date: Apr 2012
Posts: 128
Thanks: 0
Thanked 1 Time in 1 Post
Blackarrow98GP is on a distinguished road
Default

Well, I can think of a few things that would cause the engine to idle higher than normal; vacuum leak, skewed ECT sensor, bad IAC motor. Which engine do you have? 3.4L?
Blackarrow98GP is offline   Reply With Quote
Old 06-25-2012, 02:24 PM   #9
Junior Member
Thread Starter
 
Join Date: Jun 2012
Location: Dallas, Tx
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Darkman19 is on a distinguished road
Default

ive just replaced this 02 sensor and its still burnin alot of gas,,,yet when i put the car on he machine it says nothin is wrong but a person knows their vehicles so something has gotta be wrong with it..
Darkman19 is offline   Reply With Quote
Old 06-25-2012, 07:16 PM   #10
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,636
Thanked 990 Times in 769 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

If its throwing check engine lights, you need to get us those codes FIRST. We can't do anything else until we see the codes, and advise from there. Otherwise we are playing guessing games all day long.
Mike is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A few issues.... Merlin 91/97 1987-1991 7 05-18-2003 09:06 PM
Idling issues lazicn 1987-1991 3 04-17-2003 03:33 PM
Oil Pressure Issues Edmund944 1992-1999 14 04-02-2003 03:22 PM
2 issues I need help with Jrios 2000-2005 3 01-31-2003 06:54 PM
89 SSE electrical issues and more Tonyrodz 1992-1999 15 09-24-2002 12:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.