Battery or Alternator Mystery - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-07-2011, 03:44 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2009
Location: West Coast
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
1989OldsRocket88 is on a distinguished road
Default Battery or Alternator Mystery

Drove home tonight from a dinner and noticed the dash lights were dimmer than normal. Got home and left 2 hours later to return a movie a few minutes away and after dropping it couldn't start the car. Not enough juice to crank. Got a jump and drove home and as soon as I got home tried to start again to check it and no start again, won't turn over again.

I put in a new battery less than 2 years ago. New alternator about just over a year ago after the previously new one failed after a few months when pulley seized. I checked the battery by popping the tops off and all cells covered with water but one cell has a slight build up of white stuff starting on the side(under the water). Charging the battery now and it read 8V when I hooked up the charger and started charging.

I'm guessing the alternator is not charging. Can an autoparts store test the alternator easily if I take it off and bring it in?
1989OldsRocket88 is offline   Reply With Quote
Old 03-07-2011, 04:31 AM   #2
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2009
Location: West Coast
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
1989OldsRocket88 is on a distinguished road
Default

One more thing, when I try to start the car the defroster automatically turns on even though car wont turn over.
1989OldsRocket88 is offline   Reply With Quote
Old 03-07-2011, 04:41 AM   #3
Senior Member
Posts like a Supercharger
 
Join Date: Feb 2011
Location: Margate, UK
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
rustyroger is on a distinguished road
Default

Get a multimeter and check the voltage across the battery when the engine is running. It should show 13.5 - 15 volts if the alternator is working, a low reading indicates not charging properly, a higher reading indicates overcharging - a faulty regulator.
The defroster coming on sounds like a faulty relay, probably a seperate fault to your charging issues.
Have any warning lights come on? or not come on as in the charge warning light should be lit before the engine starts and go out when it is running.
Hope this helps.
Roger.
rustyroger is offline   Reply With Quote
Old 03-07-2011, 04:50 AM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2009
Location: West Coast
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
1989OldsRocket88 is on a distinguished road
Default

Just tested the alternator with a multimeter as per youtube video - Battery reads 12.6 - 12.8V when car off and reads around 12-12.6V when car running, 11.9 when defrost and lights on, so looks like its a bad alternator. Alternator seems also to have a odd smell from it like electrical burning smell but no smoke or anything like that.
1989OldsRocket88 is offline   Reply With Quote
Old 03-07-2011, 04:54 AM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2009
Location: West Coast
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
1989OldsRocket88 is on a distinguished road
Default

Quote:
Originally Posted by rustyroger View Post
Get a multimeter and check the voltage across the battery when the engine is running. It should show 13.5 - 15 volts if the alternator is working, a low reading indicates not charging properly, a higher reading indicates overcharging - a faulty regulator.
The defroster coming on sounds like a faulty relay, probably a seperate fault to your charging issues.
Have any warning lights come on? or not come on as in the charge warning light should be lit before the engine starts and go out when it is running.
Hope this helps.
Roger.
Thanks for the info, you replied while I was writing my last post! No warning lights, charging light is on b4 engine starts and goes out when running.

I guess its pretty clear its a bad alternator then.
1989OldsRocket88 is offline   Reply With Quote
Old 03-07-2011, 05:02 AM   #6
Senior Member
Posts like a Supercharger
 
Join Date: Feb 2011
Location: Margate, UK
Posts: 199
Thanks: 0
Thanked 0 Times in 0 Posts
rustyroger is on a distinguished road
Default

Glad to hear you pinned down the problem, always happy to try to help.
rustyroger is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Whiney alternator - update - probably not the alternator vital49 2000-2005 11 02-05-2008 10:52 PM
92 SE Battery/alternator/electrical problem? Cyz 1992-1999 6 03-21-2005 04:53 PM
OMG this confuses me so much GRR not battery not alternator? killer_cr80r Lounge 5 08-27-2004 10:23 AM
Alternator or Battery? randallons General GM Chat 1 08-26-2003 04:17 PM
MSD coils killed my alternator and my battery........ NoControl 1992-1999 7 08-11-2003 02:39 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.