Another friggin' problem.... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-31-2004, 04:00 PM   #1
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default Another friggin' problem....

Well, I have encountered another friggin problem. The little digital (compass and drivers imfo center thing)readout things in the dash have dissappeared. They aren't even showing anything. I noticed that they started to flicker a couple days ago. Whats going on. I am starting to get sick of these problems.
beckstyle is offline   Reply With Quote
Old 12-31-2004, 04:03 PM   #2
Sol
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 8,909
Thanks: 0
Thanked 0 Times in 0 Posts
Sol is on a distinguished road
Default

Does your speedo and RPM gauge still light up when the headlights go on?
Sol is offline   Reply With Quote
Old 12-31-2004, 04:08 PM   #3
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

Yes they do.
beckstyle is offline   Reply With Quote
Old 12-31-2004, 04:10 PM   #4
Senior Member
True Car Nut
 
GAMEOVER's Avatar
 
Join Date: Aug 2003
Location: Racine Wi
Posts: 5,146
Thanks: 0
Thanked 0 Times in 0 Posts
GAMEOVER is on a distinguished road
Default

you might have a short in your gauge cluster
GAMEOVER is offline   Reply With Quote
Old 12-31-2004, 04:11 PM   #5
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

Quote:
Originally Posted by GAMEOVER
you might have a short in your gauge cluster


I've had quite a bit of problems. I should have gotten a 93......
beckstyle is offline   Reply With Quote
Old 12-31-2004, 04:11 PM   #6
Junior Member
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

I know how you feel. It'* typical of higher mileage older cars. Sounds to me like your dash isn't connecting to the connectors behind it. The dash is plug'n play. There are no cables going to the dash, it just has a connector that slides into connector behind it. Over time the connectors either become loose or dirty. You usually have to take the dash apart and clean them to fix the problem. I think that'* why GM went back to using the 'old fashioned' wire harnesses in later years.
Custom88 is offline   Reply With Quote
Old 12-31-2004, 04:12 PM   #7
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

Now I have to fix that too........


I don't know if I'm going to catch a break.
beckstyle is offline   Reply With Quote
Old 12-31-2004, 04:15 PM   #8
Junior Member
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

This should be of some help. Good luck!
http://www.bonnevilleclub.com/techinfo/?article=56
Custom88 is offline   Reply With Quote
Old 12-31-2004, 04:19 PM   #9
Senior Member
Certified GM nut
Thread Starter
 
Join Date: Jun 2004
Location: Grand Haven, Michigan
Posts: 1,719
Thanks: 0
Thanked 0 Times in 0 Posts
beckstyle is on a distinguished road
Default

WEll, I have an appointment at a shop (that actually specializes in 3800s ) for the whole gas tank, baffle thing. So, hopefully I will have them look at that as well.
beckstyle is offline   Reply With Quote
Old 12-31-2004, 04:21 PM   #10
Senior Member
True Car Nut
 
Join Date: Apr 2004
Location: Three Oaks, Michigan
Posts: 4,879
Thanks: 0
Thanked 0 Times in 0 Posts
opensourceguy is on a distinguished road
Default

Seems like someone has a case of the 87-91 SSE cluster BS. The best you can do, is pull the dash pad, and clean all the contacts for your cluster. If that doesn't work... i think I may need to dig the dust off my cluster work.. there is something in the compass that prevents both compass and DIC from operating.. When you pull the cluster, pull the compass out, and see if you can find any cracks in some electrical components, or burned stuff.. etc. I can pull my cluster in under 5 minutes [i've also done it a million times].. so it isn't a huge deal.. so don't worry about that. Take some pics if you can..


-justin
opensourceguy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Friggin' Lawyers J Wikoff Lounge 27 09-10-2007 12:34 PM
Winter Storm 2004 PICS!! 56K no friggin way 1993 SLE Lounge 3 02-26-2004 10:15 PM
s'bout friggin time Sol Lounge 6 01-09-2004 10:11 PM
Friggin Cactus!! MOS95B Lounge 2 11-20-2003 05:22 PM
I friggin HATE the local auto shops!!! Allmachtige Lounge 11 07-24-2003 01:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.