2001 Century Tranny - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-03-2012, 03:08 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
BrotherAli is on a distinguished road
Default 2001 Century Tranny

Backstore: Car was neglected, tranny fluid wasnt changed for 160k miles and yet ran 100%. Recently I dropped the pan and changed the filter/fluid with dex III/merc. Now I started to notice that after 30+mins of driving with a decent amount of stop n go driving that the shifts get noticeably harsher (especially if I accelerate slow) and there is a very faint whinnying sound.

I have decided to change the thermostat to the 180 one with hole drilled since we noticed the engine was running hotter after we changed it the first time while doing the intake manifold (we changed since we were already there but I guess we got a hotter one or something because ever since we noticed it runs alittle hotter)....This should keep the radiator cooler and hopefully help the tranny stay cooler

Which fluid should I get? Going to change the fluid as well since this harsh shifting happened after changing it.
BrotherAli is offline   Reply With Quote
Old 11-03-2012, 08:40 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

your engine will not run right without the proper thermostat it should be 195. if its running hot try taking the fans out and back washing the rad with a hose and simple green. also the gauge may not be accurate, i try a ir temp gun and verify the temp gauge to that. as far as the fluid they are up to IV i think and gm says its for all vehicles
jwfirebird is offline   Reply With Quote
Old 11-03-2012, 08:45 AM   #3
Senior Member
Posts like a Northstar
 
1REDCAV's Avatar
 
Join Date: Aug 2010
Location: Mesa, AZ
Posts: 577
Thanked 5 Times in 5 Posts
1REDCAV is on a distinguished road
Default

I think I would've flushed the tranny, since it was a very long time since the fluid/filter were changed. I agree with Justin about the proper thermostat for your vehicle, should keep it at 195.
1REDCAV is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2001 Buick Century Custom Timing Chain cover gasket kycollins Buick 1 11-21-2013 01:12 PM
2001 Century - PS Pump Mickman Buick 1 03-09-2013 03:20 PM
2001 Bonnie SSEI tranny jumps gears. nwgizmo 2000-2005 7 11-26-2007 11:32 PM
2001 Buick Century Maymybonnieliveforevr Lounge 9 10-12-2007 10:28 AM
2001 bonneville 2001 grand prix engine Boombata Performance, Brainstorming & Tuning 10 10-10-2005 04:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.