1996 oldsmobile 88 showing p1870 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


General GM Chat When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made. Chat about all things GM (and related cars). Off-topic stuff should be in the Lounge, and all Model specific mechanical problems should be posted in the proper forum.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-22-2013, 05:57 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Joey5959 is on a distinguished road
Default 1996 oldsmobile 88 showing p1870

I have a 1996 oldsmobile 88 3.8L v6 w/o supercharger. The computer is showing code p1870. There are no signs of transmission issues. Its shifts fine, the fluid is bright red with no signs of metal shavings. I can clear the code and it comes back on within 20 miles of driving. Any ideas?
Joey5959 is offline   Reply With Quote
Old 04-23-2013, 09:47 PM   #2
Senior Member
Certified GM nut
 
SignOfZeta's Avatar
 
Join Date: Mar 2005
Location: New Milford, CT
Posts: 2,284
Thanked 16 Times in 13 Posts
SignOfZeta has a spectacular aura aboutSignOfZeta has a spectacular aura about
Default

That'* a well-known design flaw with 4T60 transmissions made before 1999. The transmission needs to be opened up to replace the valve body, but on the bright side, this is one of those problems that you probably won't notice. I put about 100,000 more miles on my Bonneville after this code first showed up.

For more information, check out our write-up about it.
SignOfZeta is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1996 Oldsmobile engine cranks but doesn't start javis Oldsmobile 11 09-23-2011 12:15 PM
1996 Oldsmobile 98 AC slow leak lawoolybear Oldsmobile 1 08-08-2010 04:53 AM
Code P1870...What does it mean??? macho_mike21 1992-1999 6 06-11-2005 03:44 PM
DTC P1870 (Transaxle Component Slipping (4T60-E Trans) throb 2000-2005 3 04-17-2003 02:48 PM
DTC P1870 (Transaxle Component Slipping (4T60-E Trans) throb 1992-1999 1 04-15-2003 08:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.