Supercharger Coupler, and more. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Forced Induction All questions and problems regarding Superchargers, Turbos, NOS, ZEX, intercoolers, water injection, etc.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-27-2003, 06:16 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2002
Location: Greenville, SC
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Wolfedog50 is on a distinguished road
Default Supercharger Coupler, and more.

Ok.. here'* the deal. I've had a rattle at idle for a long time. Ok, i know that is the coupler. Havn't replaced it yet. Going to do that soon. A new problem has arised that i think is the supercharger also. It started from when i step on the gas hard it makes the horriable grrrrrr noise. I was talk it was the bearings in the water pump..... WRONG.... still does it. It does sound like a bearing to me though. As of recent the rattle at idel has become more of a intermintant chung. It'll run ok then go Chung spraticly every 5 secs or so. When it chungs the idle pully moves a lot too. Also now when i step on the gas.. even very easy... the car jerks a little.. has some hesitation.... It still jerks a little, but not near as much at high RPM'*.... Supercharger bearings maybe.
Wolfedog50 is offline   Reply With Quote
Old 09-27-2003, 08:13 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default Re: Supercharger Coupler, and more.

Quote:
Originally Posted by Wolfedog50
Ok.. here'* the deal. I've had a rattle at idle for a long time. Ok, i know that is the coupler. Havn't replaced it yet. Going to do that soon. A new problem has arised that i think is the supercharger also. It started from when i step on the gas hard it makes the horriable grrrrrr noise. I was talk it was the bearings in the water pump..... WRONG.... still does it. It does sound like a bearing to me though. As of recent the rattle at idel has become more of a intermintant chung. It'll run ok then go Chung spraticly every 5 secs or so. When it chungs the idle pully moves a lot too. Also now when i step on the gas.. even very easy... the car jerks a little.. has some hesitation.... It still jerks a little, but not near as much at high RPM'*.... Supercharger bearings maybe.
Ok, taking this piece by piece. If you know your coupler (and it sounds like it is) is going south on you, do the nosedrive seals and bearings at the same time. You need to pull it open anyway. This will rule everything else out. However, I'd say that noise and symptom would be more likely caused by missing teeth on the gears in the SC nosedrive. This can be BAD. It can cause rotor clash. Until you really isolate it, be VERY careful.

Keep in mind that the boost is entirely bypassed at idle. The SC has no effect on idle quality normally.

How'* the oil in the nosedrive, how long since the last change, and how much boost at WOT?
willwren is offline   Reply With Quote
Old 09-28-2003, 03:51 AM   #3
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2002
Location: Greenville, SC
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Wolfedog50 is on a distinguished road
Default

The oil level is fine. It does the same kind of jumping thing at wot. It almost sounds like a very serious engine studder, but i know that it'* not the ignition system. The Chung is so bad it almost stops the engine sometimes. The boost gauge seems to be operation normal, but when i get it some gas it feels like the boost wants to cut in and help me, and does some, but cuts out a lot, and i don't get must power at all.
Wolfedog50 is offline   Reply With Quote
Old 09-28-2003, 11:12 PM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Take the belt off and rotate that */C pulley around. Is it ceasing up? Is there play in it?
fuddyduddy121 is offline   Reply With Quote
Old 09-29-2003, 12:39 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Quote:
Originally Posted by Wolfedog50
The oil level is fine. It does the same kind of jumping thing at wot. It almost sounds like a very serious engine studder, but i know that it'* not the ignition system. The Chung is so bad it almost stops the engine sometimes. The boost gauge seems to be operation normal, but when i get it some gas it feels like the boost wants to cut in and help me, and does some, but cuts out a lot, and i don't get must power at all.
Funny question.....was your climate control in AUTO or ECONOMY during your observations?
willwren is offline   Reply With Quote
Old 09-29-2003, 01:05 PM   #6
Senior Member
Posts like a 4 Banger
 
Join Date: Mar 2003
Posts: 137
Thanks: 0
Thanked 0 Times in 0 Posts
danpuzak is on a distinguished road
Default

Wow, i have that exact same problem. I was told it was just the exhaust manifolds rattling. It sounds like a bunch of rattling, like something is loose right before the car downshifts when you go to full throttle. Is this what your talking about?

I hope it'* not, because i don't need these problems right now
danpuzak is offline   Reply With Quote
Old 09-30-2003, 12:10 AM   #7
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2002
Location: Greenville, SC
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Wolfedog50 is on a distinguished road
Default

Ok.. found out was mine was... only cost about 100 bucks to fix it.... Good for me. It was the ignition thingy.... the thing that causes the spark plugs to spark. Crap.. somebody tell me what it'* called so i don't keep sounding like a moron. Sounded like Chunking becuase the engine only hit the pistion hard enough to just barley get it around.
Wolfedog50 is offline   Reply With Quote
Old 09-30-2003, 12:26 AM   #8
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

ICM? Coils?
willwren is offline   Reply With Quote
Old 09-30-2003, 07:20 AM   #9
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Nov 2002
Location: Greenville, SC
Posts: 421
Thanks: 0
Thanked 0 Times in 0 Posts
Wolfedog50 is on a distinguished road
Default

Yes.. it was the ignition coils.
Wolfedog50 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 Bonneville Supercharger coupler and bearing replacement retiredstudent Forced Induction 7 02-16-2010 01:13 PM
Supercharger Coupler and O2 Sensor Questions Ryan Forced Induction 18 03-12-2005 12:24 PM
Supercharger Coupler Replacement Wolfedog50 Forced Induction 3 08-08-2003 12:24 AM
SUPERCHARGER RATTLE FIX COUPLER miketa Performance, Brainstorming & Tuning 1 08-03-2003 02:17 PM
Supercharger coupler willwren Forced Induction 4 02-10-2003 12:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:49 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.