SC question??? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Forced Induction All questions and problems regarding Superchargers, Turbos, NOS, ZEX, intercoolers, water injection, etc.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-04-2008, 03:42 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Location: INDIANAPOLIS, IN 46237
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
mustangman_93 is on a distinguished road
Default SC question???

mustangman_93
LE Member


Joined: 04 Feb 2008
Posts: 3
Location: INDIANAPOLIS, IN 46237
Posted: Mon Feb 04, 2008 2:40 pm Post subject: SC question???

--------------------------------------------------------------------------------

When the car is at idle it has a knocking sound, when I removed the SC belt the knocking sound went away. Put the SC belt back on and knocking sound returned at idle. When I increased the rpms the SC quieted down to where the knocking sound was inaudible. Turned the car off and removed SC belt again and moved the pulley back and forth and felt some "slop" both ways before feeling the SC catch. What could the problem be? Also, the knocking sound does not occur at start up and becomes much more frequent the longer car runs. It definitely sounds like a rod knocking, but eliminated that when bypassed the SC. Any help would be much appreciated. Thank you very much. Bryan
_________________
1996 Bonneville SSEI, bone stock, 193000 miles
mustangman_93 is offline   Reply With Quote
Old 02-04-2008, 05:05 PM   #2
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default

Replace the coupler.

www.rollingperformance.com
www.INTENSE-racing.com
www.zzperformance.com

Pick your poison. Sealant, two bottles of oil (supercharger oil only), and a coupler.
willwren is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The question isn't will...The question is how nagel79 Audio (and aftermarket electronics) 4 07-09-2006 11:14 AM
Temp. Guage Question - Probably a n00b question... :D ten_gigahertz 2000-2005 15 03-11-2006 10:07 AM
Tranny seal softener question / tranny question satsuke 1992-1999 9 09-20-2005 09:28 PM
gearhead question...and audio question CraZyDriVer868 Audio (and aftermarket electronics) 4 10-31-2003 04:19 AM
Question about Traction Control, and Question about Jet Chip dbtk2 2000-2005 3 05-22-2003 12:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.