possible bad BCM? Body Control Module - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-28-2008, 12:27 AM   #1
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default possible bad BCM? Body Control Module

Oh man where to start on this one......

Well the car is my 96 SSEi

The problems are as follows:

(1) ECC blinks (maybe the actuator gear is broke)

(2) AC does not turn on (could just need a charge)

(3) Vents do not work, only defrost and floor (might be due to the possible actuator gear being broken) (I have confirmed that the arm does not move, looking through the glove box peep hole)

(4) None of the courtesy lights work (no fuses are blown) (haven’t done the 'bong' test yet)

(5) When I key up the ignition the air bag light does not blink or even come on at all (I noticed yesterday that the fuse for the air bag was gone so I replaced it, still does not come on. Also pulled the cluster apart and found no burnt out or missing bulbs)

(6) The ELC does not level car (the pump switch at the trunk does work)

(7) Sometimes the RKE custom program loses its memory (I mean sometimes I put car in gear and doors lock, but then sometimes they don't) (I have them set to program 4: no auto-locking)

( 8 ) Your probably asking yourself "self...why did Todd buy this car"

(9) I'm asking myself the same thing....oh well work in progress


I'm starting to think that the kid I bought this from has pretty much lied to me every step of the way, telling me that only a few things don't work and every thing else does.

Well pretty much the whole car needs to be rebuilt, not much does work right but the motor and transmission gas petal and breaks (for now)

Any help would be much appreciated.

I'm hoping that it just needs a new BCM or some other module

oh and I've done this and no dice
http://www.bonnevilleclub.com/forum/...=article&k=102


Todd
Toddster is offline   Reply With Quote
Old 04-28-2008, 01:15 PM   #2
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Help please
Toddster is offline   Reply With Quote
Old 04-28-2008, 01:31 PM   #3
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

The bcm has nothing to do with the elc. It sure sounds like you got at least a bad ground. ECC is the actuator box.
sonoma_zr2 is offline   Reply With Quote
Old 04-28-2008, 01:47 PM   #4
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Quote:
Originally Posted by sonoma_zr2
The bcm has nothing to do with the elc. It sure sounds like you got at least a bad ground. ECC is the actuator box.
Thanks


I do have a known elc level switch under the car came from a BC member

also the seloniod and relay in trunk work and the on/off switch in the trunk work as well.
In fact I can make the pump work when the key is on and press the on switch in trunk.

the car just does not level.

relay under pass side? maybe

i switch it with the horn one and no lucj there either.
Toddster is offline   Reply With Quote
Old 04-28-2008, 01:59 PM   #5
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

just did 'bong' test and found code #3 'courtesy lights'

now I just need to check MALL connections
Toddster is offline   Reply With Quote
Old 04-28-2008, 01:59 PM   #6
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

you either got a bad level switch, or you compressor is frying it. I actually had that happen to me. Went through 3 level switches before I figured it out. The switch calls for the release solenoid for a split second before the compressor turns on. This releases any cylinder compression that might make motor stall. My situation was I would plug in the new level switch and it would work once. The release solenoid was shorting out the elc switch.

If you don't get a system pump up phase about 10 seconds after key on, the elc switch is bad. We already know your compressor works, the relay under the dash is working.
sonoma_zr2 is offline   Reply With Quote
Old 04-28-2008, 02:03 PM   #7
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Quote:
Originally Posted by sonoma_zr2
you either got a bad level switch, or you compressor is frying it. I actually had that happen to me. Went through 3 level switches before I figured it out. The switch calls for the release solenoid for a split second before the compressor turns on. This releases any cylinder compression that might make motor stall. My situation was I would plug in the new level switch and it would work once. The release solenoid was shorting out the elc switch.

If you don't get a system pump up phase about 10 seconds after key on, the elc switch is bad. We already know your compressor works, the relay under the dash is working.
oh, so you are saying I need a pump?
Toddster is offline   Reply With Quote
Old 04-28-2008, 02:06 PM   #8
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

Quote:
Originally Posted by toddster
Quote:
Originally Posted by sonoma_zr2
you either got a bad level switch, or you compressor is frying it. I actually had that happen to me. Went through 3 level switches before I figured it out. The switch calls for the release solenoid for a split second before the compressor turns on. This releases any cylinder compression that might make motor stall. My situation was I would plug in the new level switch and it would work once. The release solenoid was shorting out the elc switch.

If you don't get a system pump up phase about 10 seconds after key on, the elc switch is bad. We already know your compressor works, the relay under the dash is working.
oh, so you are saying I need a pump?
It sure looks that way. When I did mine, I got a known working compressor assembly and switch from a donor. I attempted to replace the pump head, but after I twisted off 3 bolt heads I just got another compressor assembly.
sonoma_zr2 is offline   Reply With Quote
Old 04-28-2008, 02:10 PM   #9
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Quote:
Originally Posted by sonoma_zr2
Quote:
Originally Posted by toddster
Quote:
Originally Posted by sonoma_zr2
you either got a bad level switch, or you compressor is frying it. I actually had that happen to me. Went through 3 level switches before I figured it out. The switch calls for the release solenoid for a split second before the compressor turns on. This releases any cylinder compression that might make motor stall. My situation was I would plug in the new level switch and it would work once. The release solenoid was shorting out the elc switch.

If you don't get a system pump up phase about 10 seconds after key on, the elc switch is bad. We already know your compressor works, the relay under the dash is working.
oh, so you are saying I need a pump?
It sure looks that way. When I did mine, I got a known working compressor assembly and switch from a donor. I attempted to replace the pump head, but after I twisted off 3 bolt heads I just got another compressor assembly.
hmmm...

sounds good to me

I have a lead on a working pump

Thanks

I'll let your know when I get it installed
Toddster is offline   Reply With Quote
Old 04-29-2008, 12:39 AM   #10
Junior Member
Thread Starter
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

I took apart the passenger side ground buss and found major corrosion. So I made all new connections and cleaned the metal blade/bar thing and reconnected everything.
The only real difference I just made is visually nothing, but now when I go into the MALL/ BCM test mode it only comes up with code #2 now. I must have cleared or fixed a ground that made the code #3 go away.


Code #2 in my FSM tells me...
Quote:
MALL HISTORY CODES TABLE
History Code Affected Circuit
1 ........................ FASTEN BELTS indicator (SBTELL)
2 ............................. Battery Protection (PBATT)
3 ................................. Courtesy Lights (CTSY)
my passenger side blade looked very simular to this one:

Name:  bussbar.jpg
Views: 131
Size:  70.0 KB

however when I cleaned the blade I ground it down to the next metal (brass) I think.

now what?
Toddster is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 Malibu Cold Coolant. Possible Bad Cat. Possible Bad Thermostat? Kamikaze78 Chevrolet 5 10-14-2014 08:12 AM
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Body Control Module problem???? honeydogs 1992-1999 6 10-31-2009 09:10 PM
What does the Body Contol Module Control 2000BLKBONNEVILLE Everything Electrical & Electronic 1 09-14-2009 01:46 PM
Dash intergration module aka body control module 2000BLKBONNEVILLE Everything Electrical & Electronic 0 09-10-2009 01:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.