Part of DIC blank, and buttons don't work. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-07-2008, 05:10 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
00SLE is on a distinguished road
Default Part of DIC blank, and buttons don't work.

I've had my '00 Bonneville SLE for a week or so now, and I'm finally starting to figure out what everything does. I have a problem though.

The little rectangle screen that'* supposed to show driver number or my name or whatever is blank. The outline of the car lights up, and shows when doors are open. The compass is also there, but its not right, and it will just shut off randomly and stop displaying a direction. Also, my E/M, and Trip Reset buttons are the only ones that do anything. Where should I start looking?

Thanks
00SLE is offline   Reply With Quote
Old 04-10-2008, 05:24 PM   #2
Senior Member
Posts like a Supercharger
 
Join Date: Jan 2007
Location: Missouri
Posts: 186
Thanks: 0
Thanked 0 Times in 0 Posts
skregal is on a distinguished road
Default

No one has chimed in so I'll just give you my experience. Several members including myself have had to get the DIC panel and buttons replaced by the dealer when they quit operating. Most went out with no warning, just stopped working. There may be other things to check; fuses, grounds, wire connections, etc. but someone else will have to tell you about that.
skregal is offline   Reply With Quote
Old 04-10-2008, 06:00 PM   #3
Senior Member
Posts like a Corvette
 
Join Date: Nov 2006
Location: Alberta, Canada
Posts: 1,446
Thanks: 0
Thanked 0 Times in 0 Posts
ddalder is on a distinguished road
Default

It sounds to me like you may have a problem with the cluster. I'm suspicious becuase more than (some) buttons not working, portions of the display don't work. It can be normal for your compass to stop showing a direction if it needs to be recalibrated. The DIC would display this message however.

Can I assume that when you turn on your ignition, and the self test illuminates all the cluster lights and DIC segments, that some are also not illuminating during this phase?
ddalder is offline   Reply With Quote
Old 04-10-2008, 07:04 PM   #4
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
00SLE is on a distinguished road
Default

I actually got the compass part figured out. I had a box of speakers in my trunk that I took out of my truck before I traded it. Once I took that box out the compass started working fine, and still does. The only thing on the dash that doesn't work is that little rectangle info center below the car outline and compass, and the select, mode, and reset buttons. For all I know the buttons do work, but I can't see anything change because the display is out.

I've had the dash apart a few times, fixing the lights in the radio and installing my xm and stuff, but never had the cluster apart. Is there a way to replace just that little screen?
00SLE is offline   Reply With Quote
Old 04-10-2008, 09:12 PM   #5
Senior Member
Posts like a Corvette
 
Join Date: Nov 2006
Location: Alberta, Canada
Posts: 1,446
Thanks: 0
Thanked 0 Times in 0 Posts
ddalder is on a distinguished road
Default

At a minimum, I suspect you'll need a cluster for parts. GM won't sell you this portion alone. Assuming that you can get one for parts you should be able to swap the DIC module, but my suggestion would be to buy a known good used cluster and simply swap the module that stores the mileage. This is relatively easy.

What is the answer to my question about the power-up self test and display segments?
ddalder is offline   Reply With Quote
Old 04-10-2008, 11:05 PM   #6
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
00SLE is on a distinguished road
Default

I'm assuming when you say power up self-test and display segments you mean when I first turn the key to on. When I do that, the gauges light up, the compass flips through all 4 directions and then settles on the right one. But that little display never lights up or anything.
00SLE is offline   Reply With Quote
Old 04-10-2008, 11:25 PM   #7
Senior Member
Posts like a Corvette
 
Join Date: Nov 2006
Location: Alberta, Canada
Posts: 1,446
Thanks: 0
Thanked 0 Times in 0 Posts
ddalder is on a distinguished road
Default

Yes, that'* what I was referring to. It won't actually illuminate all the pixels, but it should display "Driver 1" or "Driver 2" (other messages if they have ever been customized).

If you look for a cluster, you need to find a non-SSEi cluster that has the DIC. This leaves out the SE as well. It may be a bit of a trick to find.

One final check before you replace the cluster might be to disconnect the switches altogether and verify that the display remains blank when you turn on the car. This will verify that it isn't a stuck/grounded switch that'* confusing the cluster.
ddalder is offline   Reply With Quote
Old 04-13-2008, 11:41 PM   #8
Junior Member
 
Join Date: Apr 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
irocssei is on a distinguished road
Default cluster

what part holds your info in the cluster.could you send a pic of it if you got it.
irocssei is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
05 gxp 8k miles. climate control screen is blank and not operational mtpratt1 Everything Electrical & Electronic 2 01-10-2010 09:57 PM
calculus help, my mind has gone blank jwakamud Lounge 5 04-09-2007 03:39 AM
radio display blank flatbill Audio (and aftermarket electronics) 2 03-23-2007 06:05 PM
I have some more RPO codes to list for the ones blank... ssesc93 General GM Chat 5 05-25-2005 10:52 AM
Help!!1989SSE Seat Adjust Buttons won't work. mendedwings Everything Electrical & Electronic 9 12-27-2003 01:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.