Instrument Cluster ground issues? possibly? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-10-2010, 02:57 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Jan 2005
Location: Columbus, OH
Posts: 66
Thanks: 0
Thanked 1 Time in 1 Post
jaye22 is on a distinguished road
Default Instrument Cluster ground issues? possibly?

I am looking for anyone who can provide me with the pinout of the instrument cluster. I am having issues with my gauges pegging both high and low and will jump around randomly. I have already checked and cleaned the ground buss under the carpet on driver and passenger floorboards. I am going crazy trying to figure this out so I can have ACCURATE boost/oil/temp readings. My tach and speedometer are fine. The information LCD will reset but it is still functional. I am at a loss. Thanks for the help!!

Jason
jaye22 is offline   Reply With Quote
Old 04-15-2010, 05:14 PM   #2
Member
Posts like a V-Tak
 
jason5983's Avatar
 
Join Date: Mar 2010
Location: kentucky
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
jason5983 is on a distinguished road
Default

i had the same problem on my 94 ssei and i pulled the cluster and found the connector wasnt getting a good connection so i found a salvage yard bought a plug replaced the old one now it works fine
jason5983 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'98 Bonneville, Instrument cluster issues hotrod53 1992-1999 28 04-28-2010 01:56 PM
Service info: 1992 SSEI Instrument Cluster TelePlayer 1992-1999 1 10-02-2008 02:07 PM
GXP Instrument Cluster Issues *B2* Everything Electrical & Electronic 3 09-09-2007 03:14 PM
Gauge Cluster Help... Tried Cleaning connecions+Ground buss. xDRx Everything Electrical & Electronic 9 07-26-2007 12:07 PM
another instrument cluster question egladman 1987-1991 4 07-03-2003 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.