Ignition control module problem. - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-09-2009, 08:22 AM   #11
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Sorry for your frustrations....

Have you checked all the ground areas I suggested just to rule them out?
Toddster is offline   Reply With Quote
Old 12-09-2009, 09:42 AM   #12
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

There is always the chance the ICM is bad again. We've seen DOAs right out of the box.
Danthurs is offline   Reply With Quote
Old 12-09-2009, 10:20 AM   #13
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

good point though he bought it from Napa. Napa is known for high quality parts.....

If he bought it from Autozone then.....yeah
Toddster is offline   Reply With Quote
Old 12-11-2009, 06:10 PM   #14
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
nightriderr is on a distinguished road
Default

OK now I have found a new symtom that has directed me away from the ICM. With a scanner hooked up, there is no rpm signal. which leads me to believe the crank sensor is bad but still giving waveform, or I have a bad wire from ck sensor to pcm? Anyway, need to do some more digging. ALL grounds seem to be in good shape. Correct me if I am wrong , when there is no rpm signal from ck sensor the pcm will not allow the icm to work or the injectors to pulse. Right ???

Narrowing Frustration.
nightriderr is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ignition Control Module (ICM) plug test Danthurs Trouble shooting + Test Procedures 0 10-03-2009 04:21 PM
Dash intergration module aka body control module 2000BLKBONNEVILLE Everything Electrical & Electronic 0 09-10-2009 01:43 PM
Aftermarket Ignition Control Module; 1989 Olds Delta 88; 3800 Vin C 96Bonne124 1987-1991 1 05-10-2009 01:10 AM
Ignition Control Module Jagman04 Performance, Brainstorming & Tuning 8 07-31-2004 12:33 PM
Ignition Control Module A Bonnie Canuck 1992-1999 5 05-31-2004 10:43 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.