Hello Im new 1999 Bonneville Dash Lights went out! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-24-2008, 12:16 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
BigNate005 is on a distinguished road
Default Hello Im new 1999 Bonneville Dash Lights went out!

Hello Short and simple

My Dash lights stop workin last night. My interior lights work juss fine and when i move the headlight switch they go on and off. My blinker work my check engine light and check gauges light still work my radio is aftermarket so that is always bright. the only light that dont light up are my gauges everything else works if someone could plz help i would be thankfull

I have a 1999 Pontaic Bonn. 3.8 SE
BigNate005 is offline   Reply With Quote
Old 02-24-2008, 03:15 PM   #2
Senior Member
True Car Nut
 
Join Date: Mar 2004
Location: Ames, Iowa
Posts: 3,066
Thanks: 0
Thanked 1 Time in 1 Post
bill buttermore is on a distinguished road
Default

Systematic electrical system troubleshooting will reveal the problem. I'll just venture a guess because this is often caused by a bad headlight switch.
bill buttermore is offline   Reply With Quote
Old 02-24-2008, 03:22 PM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
BigNate005 is on a distinguished road
Default

Hey someone responed ! YA well ya i did some troubleshootin i checked all the possible fusses by the driver side under steering wheel and under hood all look good. My next guess also is that it is the swtich cause when i beat on the dash around the switch today it came on and then went off :( I thought i had it lol i juss dont know how to go about replaceing that
BigNate005 is offline   Reply With Quote
Old 02-24-2008, 03:37 PM   #4
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

Did you try turning the dimmer to the brightest position?
Should be fuse 8B.
Try cleaning the ground bus. http://www.bonnevilleclub.com/forum/...=article&k=102
I can post a wiring diagram if that will help.
Technical Ted is offline   Reply With Quote
Old 02-24-2008, 03:58 PM   #5
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
BigNate005 is on a distinguished road
Default

Ya i got it on the brightest setting but never thought of the ground ill try that and for that detail info and pics of it U ROCK
BigNate005 is offline   Reply With Quote
Old 02-24-2008, 04:07 PM   #6
Junior Member
Thread Starter
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
BigNate005 is on a distinguished road
Default

ok i juss looked there and i saw a bunch of wires but no connecter like the 1 u got there is urz a 1999 bonn or am i doing something wrong ?
BigNate005 is offline   Reply With Quote
Old 02-24-2008, 04:40 PM   #7
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

The pictures are from an earlier model but they're in the same place on the 99. Look for a bunch of black wires & the connector will be wrapped in black tape.
Technical Ted is offline   Reply With Quote
Old 02-25-2008, 01:38 AM   #8
Senior Member
True Car Nut
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

You aren't the only one with this problem in a 99 Bonneville. I'm going to be putting a different headlight switch in tomorrow and will post back tomorrow night.
I to first experienced this when I installed an Alpine deck last summer. Switching a factory deck back in didn't fix anything -only made it worse. If you put a stock radio back in I bet you'll experience battery draining problems due to a bad power antennae relay -I know, because I did 3 times -on my old 99 SSEi, my old 98 SSE, and my current 99 SSEi.
OLBlueEyesBonne is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Running Lights & Dash Lights Stay on (Help!) jschevy01 2000-2005 19 07-22-2007 10:27 PM
dash lights and tail lights just went out tgunder Everything Electrical & Electronic 7 06-02-2007 08:48 PM
93' SSE Head lights on = No dash/radio lights awsomeears 1992-1999 4 10-03-2006 01:33 AM
One year since the "lights went out" valerka Lounge 12 08-14-2004 11:38 PM
My lights went out on my heating/cooling controls cyhill99 1992-1999 4 04-07-2003 04:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.