Guages - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-26-2006, 01:34 PM   #11
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

This seems more like a connector or pre cluster issue. If the speedo and other stuff also went wonky..then I'd think cluster.

What types of behavior..low readings..bouncing back and forth?
BillBoost37 is offline   Reply With Quote
Old 12-26-2006, 03:29 PM   #12
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

I had that same issue with a '93 SSE. Tach and speedo always worked. The rest, whenever they felt like it. No rhyme or reason as to when. I had the dash apart 3 times to clean the connections. That didn't help. Finally, touching up connections on the circuit board with a soldering iron took care of the problem. Work on the larger connections where the boards connect together, and any place where flexing caused by heavier components can occur.
Archon is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
not audio...electronics...digital guages Nebraska1990LE Audio (and aftermarket electronics) 3 07-08-2004 03:22 PM
Which guages? J Wikoff General GM Chat 4 02-17-2004 04:07 PM
A pillar GUAGES/POD boseman350 General GM Chat 66 04-23-2003 05:14 PM
Guages fluctuating 1992 3.8l se BarryBoy 1992-1999 26 04-22-2003 11:46 AM
Red individual guages for guage pod? Widerman Performance, Brainstorming & Tuning 0 03-17-2003 10:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.