blower on all the time - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-17-2008, 07:13 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default blower on all the time

Got a 96. blower motor stays on all the time except when i turn key off. this is the electronic version. It will not change speeds but when i hit the off button it will not go off. Tried changing motor and module. Still not turning off till i turn key off. What can it be? I have also tried unplugging the control head on the dash and it will still run. Shouldnt it turn off when the head is disconnected? anyone have a wiring diagram?
berlincam86 is offline   Reply With Quote
Old 11-17-2008, 08:39 PM   #2
Senior Member
Posts like a Corvette
 
crunkfrunk's Avatar
 
Join Date: Jun 2008
Location: Cleveland, OH
Posts: 1,389
Thanks: 0
Thanked 0 Times in 0 Posts
crunkfrunk is on a distinguished road
Default

from working on other cars with electronic climate controls taking out the controller makes the fan turn on, but i cant say what would make it stay on all the time except maybe a bad controller?
crunkfrunk is offline   Reply With Quote
Old 11-17-2008, 09:56 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default

I tryed a new control module. the one next too the blower motor and its doing the same thing. Is there another controller somewhere? Or are you talkin about the controller on the dash?
berlincam86 is offline   Reply With Quote
Old 11-18-2008, 07:40 AM   #4
Senior Member
Posts like a Corvette
 
crunkfrunk's Avatar
 
Join Date: Jun 2008
Location: Cleveland, OH
Posts: 1,389
Thanks: 0
Thanked 0 Times in 0 Posts
crunkfrunk is on a distinguished road
Default

yah the one on the dash, thats odd, ive never heard of a problem like that, you checked all the fuses under the hood and on the interior? weird stuff can happen sometimes, but there might be something else that controls it too that might be the problem, cant say
crunkfrunk is offline   Reply With Quote
Old 11-18-2008, 09:44 AM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default

man i hate just throwing parts at this. I really didnt have the money to get the other parts. I wish i could find a wiring diagram.
berlincam86 is offline   Reply With Quote
Old 11-18-2008, 04:36 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

The resistor pack (or controller, for the automatic HVAC systems) that installs in the duct near the blower motor is for the lower fan speeds. If yours is running on High at all times, it sounds like the high-speed override relay is stuck on instead. This is the relay that closes when you dial up Max A/C.

If the firewall layout of yours is similar to my '93, you've got a MaxiFuse Relay Center under a cover on the firewall, with a row of relays on it, one of them being the high-speed blower relay. I don't have the specifics here with me, but maybe that'* a direction you can look into.
acg_ssei is offline   Reply With Quote
Old 11-19-2008, 12:13 AM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default

I tried removing all of those relays. And still the same.
berlincam86 is offline   Reply With Quote
Old 11-22-2008, 12:25 AM   #8
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default

someone please help. I did find a controller under the passenger side dash that i guess could be the problem too but wow $300. I cant afford that much of a guess. Could someone help with testing these items? schematics?
berlincam86 is offline   Reply With Quote
Old 11-22-2008, 12:42 AM   #9
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I wish I had something to offer but other then a stuck relay I can think of nothing. It'* a long shot but you can try checking the grounds along the rocker panels under the front doors. If these get corroded they can cause some strange things to happen.
Danthurs is offline   Reply With Quote
Old 11-22-2008, 12:47 AM   #10
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
berlincam86 is on a distinguished road
Default

im just wondering if i got a bad controller (the one next to the blower motor) from the dealer. But i had to go halfway across the world to get it. I had a caddy doin almost the same thing except the blower was running even with the key off and that one was the controller next to the blower motor so i was sure that was this too.
berlincam86 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
All GM All the Time Huckleberry Introductions for new members 6 01-01-2014 02:00 PM
Cause of bad blower motor control module? Blower motor stays on. 1995 Park Avenue. Pepin Everything Electrical & Electronic 4 07-25-2011 05:00 PM
Blower Control Module & Blower Resistor, Where are they hunter2423 1992-1999 7 05-11-2007 08:53 PM
turns out i've had an engine all this time after all.. gbrl21 Your Ride: GM Pictures & Videos 7 07-23-2006 02:46 PM
1998 SSE: blower motor non-functional at all settings 1998SLE 1992-1999 18 09-21-2005 10:06 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.