Amp draining battery. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-20-2007, 07:10 PM   #1
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default Amp draining battery.

I found my amp for my radio was draining my battery after car was shut off and rectified that by pulling 20 A fuse from under the seat fuse box .How would I go about troubleshooting this .Is the amp separate from the radio (It is all factory)?Should I replace it or do I track down wires?
jdq is offline   Reply With Quote
Old 11-21-2007, 12:09 AM   #2
Senior Member
True Car Nut
 
Join Date: May 2003
Location: Lethbridge, Alberta, _______Canada._______ West Coast Bonneville Fest ___05,06,07 Survivor___
Posts: 8,134
Thanks: 0
Thanked 0 Times in 0 Posts
SSEimatt93 is on a distinguished road
Default

Just to clarify as there is two Bonnevilles in your Sig, Which one?
The SSE should have the sperate Gain control amp and the SSEi should have the sperate Bose Amp, so its really a toss up
SSEimatt93 is offline   Reply With Quote
Old 11-21-2007, 12:20 AM   #3
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

Sorry it is the 00 ssei and thanks.Is the amp in same spot on floor behind console below radio.
jdq is offline   Reply With Quote
Old 11-21-2007, 01:29 AM   #4
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

Looks like behind the rear seat back.
Amp
Archon is offline   Reply With Quote
Old 11-21-2007, 02:01 AM   #5
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

Thanks .
jdq is offline   Reply With Quote
Old 11-22-2007, 07:24 PM   #6
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

Well I guess its more than an amp.I decicded to get a new battery anyway and today when I parked the car and got out the brake lights stayed on.So I started the car and moved it and the brake lights were off.I tried the 10 A multi meter check on the neg battery cable and neg post and am receiving 1.0 amps , I pulled all fuses and stayed 1.0 a.( I did not pull all big square fuse/ relay.Am I doing this right? Where should I continue searching?Help wife is bugging to sell.
jdq is offline   Reply With Quote
Old 11-22-2007, 08:15 PM   #7
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

Is the high center mounted brake light also staying on?
Technical Ted is offline   Reply With Quote
Old 11-22-2007, 09:09 PM   #8
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

Not sure you mean the little 3rd brake light, I dont remember.I think it is more then those that are drawing current , but I have pulled every fuse in rear seat and engine compt.There is no fuse for the theft deterrant system how can I disconnect this to check for draw.
jdq is offline   Reply With Quote
Old 11-22-2007, 10:58 PM   #9
Senior Member
Certified GM nut
 
Join Date: Oct 2005
Location: Western New York
Posts: 1,942
Thanks: 0
Thanked 0 Times in 0 Posts
Technical Ted is on a distinguished road
Default

The theft deterrent module gets power from the same fuse as the PCM.

I have several wiring diagrams that I can send if you PM me with an email address. They're very confusing but may help.

Were the brake lights staying on a one time thing or are they still doing it?
Technical Ted is offline   Reply With Quote
Old 11-22-2007, 11:35 PM   #10
jdq
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: Nov 2005
Location: Hamilton, Ontario , Canada
Posts: 1,201
Thanks: 0
Thanked 0 Times in 0 Posts
jdq is on a distinguished road
Default

pm sent
Ya I only noticed the brake lights on one time,I got myself a service manual , having a hard time with alot of those diagrams.Thanks
jdq is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery draining overnight chuckt Everything Electrical & Electronic 14 12-10-2007 11:09 AM
$&)$&*)#&+()#%& )#@(%&#)%*(&+_ Maymybonnieliveforevr Lounge 6 05-02-2007 07:07 PM
HELP! aftermarket HU is draining the battery! webbman81 Audio (and aftermarket electronics) 1 08-31-2005 07:04 PM
Draining battery Niloc 1987-1991 3 04-03-2005 02:05 PM
Blown speaker draining battery dathotbrotha Audio (and aftermarket electronics) 3 09-17-2004 12:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.