95 Bonnevile not getting gas - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-05-2009, 04:06 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ci_ph_er is on a distinguished road
Default 95 Bonnevile not getting gas

When I turn the switch to on I get a "gauge" light along with the check engine light with the engine not running. The engine does not run it does however cranks. I checked the pressure on the fuel line and it was low. I changed the fuel filter. The fuel pump does not turn on. I checked the fuel pump fuse and relay and they seem to be working good. I checked the voltage comming from the ECM and it is not there. I suspect that it is a oil pressure switch. Question is this a good assumption and where is the oil pressure switch located at in this vehicle? Second what else could cause this problem? Thanks.
ci_ph_er is offline   Reply With Quote
Old 03-05-2009, 04:17 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Do you have a VATs in your car? Take a look at this write up and see if it helps.

Also, welcome to the Bonneville forum.

https://www.gmforum.com/t279119/
Danthurs is offline   Reply With Quote
Old 03-05-2009, 11:50 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ci_ph_er is on a distinguished road
Default The engine cranks

Thanks for the post. The engine cranks over and there is no security light. The problem is that the engine is not getting any fuel. Does anyone know what troubleshooting steps I should take to narrow it to a bad part?
ci_ph_er is offline   Reply With Quote
Old 03-05-2009, 11:56 PM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

If no fuel that leaves a bad pump, blown fuse, bad relay. Check the fuse, if good, test the relay. https://www.gmforum.com/t279561/ If good, check the fuel pump.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cruise Control not working on 1995 Pontiac Bonnevile SE thomasfreese General GM Chat 0 12-29-2011 05:44 PM
Gas pedal extenders for '96 Bonnevile ladybug6 1992-1999 2 06-22-2007 12:26 PM
Richard Petty edition bonnevile? Red Baron Lounge 4 12-19-2003 01:22 PM
Getting new job.. getting paid, getting mods Wolfedog50 Performance, Brainstorming & Tuning 3 05-08-2003 02:31 PM
Diagnostics on 89 Bonnevile LE k2skiman69 1987-1991 10 05-02-2003 10:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.