1996 bonneville ground buss - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-17-2011, 06:25 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: north east pa
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
archersteve1 is on a distinguished road
Default 1996 bonneville ground buss

my 96 bonneville keeps stalling while i am driveing. i was told it may be the ground buss.
has any one else had this problem? if so can you please tell me where it is ,what it looks like
and how to fix it? thanks
archersteve1 is offline   Reply With Quote
Old 11-17-2011, 09:35 PM   #2
Senior Member
Posts like a Turbo
 
Crece's Avatar
 
Join Date: Mar 2009
Location: Richmond,Va.
Posts: 342
Thanks: 0
Thanked 0 Times in 0 Posts
Crece is on a distinguished road
Default

Welcome to the forum Archersteve1. Here is a link that Danthurs put together. Just scroll down to the hyperlink for ground buss.

https://www.gmforum.com/electrical-133/electrical-index-285307/
Crece is offline   Reply With Quote
Old 11-21-2011, 01:50 PM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: north east pa
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
archersteve1 is on a distinguished road
Default

Thank you. I found and cleaned the buss. I hope this solves the problem.
archersteve1 is offline   Reply With Quote
Old 11-22-2011, 03:16 AM   #4
Senior Member
Posts like a Turbo
 
Crece's Avatar
 
Join Date: Mar 2009
Location: Richmond,Va.
Posts: 342
Thanks: 0
Thanked 0 Times in 0 Posts
Crece is on a distinguished road
Default

Let us know if it does or does not solve the problem.. Just post to this thread instead of starting a new one. That way the entire process is documented for someone else and everyone is aware of what suggestins have already been made.
Crece is offline   Reply With Quote
Old 11-25-2011, 04:32 PM   #5
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: north east pa
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
archersteve1 is on a distinguished road
Default

Well this did not solve my problem.I know its not plugs and wires they are new. does any one have any ideas this is making me crazy. the car has 224,000 mile and runs strong but it stalls. I am ready to give up and put a for sale sign in the window.
archersteve1 is offline   Reply With Quote
Old 11-25-2011, 09:37 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Test the fuel pressure. You should have around 48psi. A bad crank sensor can cause the engine to stall as well. But testing that is a bit involved.
Danthurs is offline   Reply With Quote
Old 11-26-2011, 06:19 PM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

is there any pattern to the stalling, when the engine is hot, or cold, random. when idling,driving down the highway etc? any codes?
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 SSE, Crank but NO start, Ground BUSS? iwin12 Everything Electrical & Electronic 2 12-17-2008 07:24 AM
Gauge Cluster Help... Tried Cleaning connecions+Ground buss. xDRx Everything Electrical & Electronic 9 07-26-2007 12:07 PM
Ground Buss cleaning emceepecks Everything Electrical & Electronic 13 10-18-2006 04:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.